GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

All vulnerabilities
GHSA-m27r-m6rx-mhm4critical9.8

Laravel Redis Horizontal Scaling Insecure Deserialization

Check your stack

The advisory, in context

Impact

This vulnerability affects Laravel Reverb versions prior to v1.7.0 when horizontal scaling is enabled (REVERB_SCALING_ENABLED=true).

The exploitability of this vulnerability is increased because Redis servers are commonly deployed without authentication.

With horizontal scaling enabled, Reverb servers communicate via Redis PubSub. Reverb previously passed data from the Redis channel directly into PHP’s unserialize() function without restricting which classes could be instantiated.

Risk: Remote Code Execution (RCE)

Patches

This vulnerability is fixed in Laravel Reverb v1.7.0.

Update your dependency to laravel/reverb: ^1.7.0 immediately.

Workarounds

If you cannot upgrade to v1.7.0, you should apply the following mitigations:

  • Redis Security: Require a strong password for Redis access and ensure the service is only accessible via a private network or local loopback.
  • Disable Scaling: If your environment uses only one Reverb node, set REVERB_SCALING_ENABLED=false to bypass the vulnerable logic entirely.

Credits

This vulnerability was discovered and responsibly reported by Mohammad Yaser Abo-Elmaaty @m0h4mmad

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 1.7.0

Fixed in 1.7.0

34 explicitly affected versions

v1.0.0, v1.0.0-beta1, v1.0.0-beta10, v1.0.0-beta11, v1.0.0-beta12, v1.0.0-beta13, v1.0.0-beta14, v1.0.0-beta2, v1.0.0-beta3, v1.0.0-beta4, v1.0.0-beta5, v1.0.0-beta6, v1.0.0-beta7, v1.0.0-beta8, v1.0.0-beta9, v1.1.0, v1.2.0, v1.3.0, v1.3.1, v1.4.0, v1.4.1, v1.4.2, v1.4.3, v1.4.4, v1.4.5, v1.4.6, v1.4.7, v1.4.8, v1.5.0, v1.5.1, v1.6.0, v1.6.1, v1.6.2, v1.6.3

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "1.7.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.0.0",
    "v1.0.0-beta1",
    "v1.0.0-beta10",
    "v1.0.0-beta11",
    "v1.0.0-beta12",
    "v1.0.0-beta13",
    "v1.0.0-beta14",
    "v1.0.0-beta2",
    "v1.0.0-beta3",
    "v1.0.0-beta4",
    "v1.0.0-beta5",
    "v1.0.0-beta6",
    "v1.0.0-beta7",
    "v1.0.0-beta8",
    "v1.0.0-beta9",
    "v1.1.0",
    "v1.2.0",
    "v1.3.0",
    "v1.3.1",
    "v1.4.0",
    "v1.4.1",
    "v1.4.2",
    "v1.4.3",
    "v1.4.4",
    "v1.4.5",
    "v1.4.6",
    "v1.4.7",
    "v1.4.8",
    "v1.5.0",
    "v1.5.1",
    "v1.6.0",
    "v1.6.1",
    "v1.6.2",
    "v1.6.3"
  ]
}

References