GHSA-jxg5-35fj-ccwfhigh8.1
Extbase for TYPO3 allows RCE
The advisory, in context
Extbase in TYPO3 4.3.0 before 6.2.24, 7.x before 7.6.8, and 8.1.1 allows remote attackers to obtain sensitive information or possibly execute arbitrary code via a crafted Extbase action.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms-extbase Packagist
Ecosystem versions
Earlier releases before 6.2.24
Fixed in 6.2.24
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "6.2.24"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms-extbase Packagist
Ecosystem versions
From 7.0 before 7.6.8
Fixed in 7.6.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0"
},
{
"fixed": "7.6.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms-extbase Packagist
1 explicitly affected versions
8.1.1
View affected-version evidence
{
"ranges": [],
"versions": [
"8.1.1"
]
}