starcitizentools/citizen-skin allows stored XSS in preference menu heading messages
The advisory, in context
Summary
Various preferences messages are inserted into raw HTML, allowing anybody who can edit those messages to insert arbitrary HTML into the DOM.
Details
The innerHtml of the label div is set to the textContent of the label, essentially unsanitizing the system messages:
https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/407052e7069bdeae927d6f1a2a1c9a45b473bf9a/resources/skins.citizen.preferences/addPortlet.polyfill.js#L18
PoC
- Edit
citizen-feature-custom-font-size-name(or any other message displayed in a heading in the preferences menu) to<img src="" onerror="alert('citizen-feature-custom-font-size-name')">(script tags don't work here due to the way the HTML is inserted) - Open the preferences menu
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.13.0 before 3.3.1
Fixed in 3.3.1
53 explicitly affected versions
v2.13.0, v2.13.1, v2.13.2, v2.13.3, v2.13.4, v2.13.5, v2.14.0, v2.14.1, v2.15.0, v2.15.1, v2.16.0, v2.16.1, v2.17.0, v2.17.1, v2.17.2, v2.18.0, v2.18.1, v2.19.0, v2.20.0, v2.21.0, v2.22.0, v2.22.1, v2.23.0, v2.24.0, v2.25.0, v2.26.0, v2.27.0, v2.28.0, v2.29.0, v2.30.0, v2.31.0, v2.32.0, v2.33.0, v2.34.0, v2.35.0, v2.36.0, v2.37.0, v2.38.0, v2.38.1, v2.38.2, v2.38.3, v2.39.0, v2.39.1, v2.39.2, v2.39.3, v2.39.4, v2.40.0, v2.40.1, v2.40.2, v3.0.0, v3.1.0, v3.2.0, v3.3.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.13.0"
},
{
"fixed": "3.3.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.13.0",
"v2.13.1",
"v2.13.2",
"v2.13.3",
"v2.13.4",
"v2.13.5",
"v2.14.0",
"v2.14.1",
"v2.15.0",
"v2.15.1",
"v2.16.0",
"v2.16.1",
"v2.17.0",
"v2.17.1",
"v2.17.2",
"v2.18.0",
"v2.18.1",
"v2.19.0",
"v2.20.0",
"v2.21.0",
"v2.22.0",
"v2.22.1",
"v2.23.0",
"v2.24.0",
"v2.25.0",
"v2.26.0",
"v2.27.0",
"v2.28.0",
"v2.29.0",
"v2.30.0",
"v2.31.0",
"v2.32.0",
"v2.33.0",
"v2.34.0",
"v2.35.0",
"v2.36.0",
"v2.37.0",
"v2.38.0",
"v2.38.1",
"v2.38.2",
"v2.38.3",
"v2.39.0",
"v2.39.1",
"v2.39.2",
"v2.39.3",
"v2.39.4",
"v2.40.0",
"v2.40.1",
"v2.40.2",
"v3.0.0",
"v3.1.0",
"v3.2.0",
"v3.3.0"
]
}References
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-jwr7-992g-68mh
- https://nvd.nist.gov/vuln/detail/CVE-2025-49577
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/93c36ac778397e0e7c46cf7adb1e5d848265f1bd
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/a741639085d70c22a9f49890542a142a223bf981
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen