Roots Soil plugin vulnerable to Cross-site Scripting
The advisory, in context
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.1.0. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.1 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 4.1.0
Fixed in 4.1.0
25 explicitly affected versions
3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.5.0, 3.6.0, 3.6.1, 3.6.2, 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.8.0, 3.8.1, 3.9.0, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.1.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.1",
"3.0.2",
"3.0.3",
"3.1.0",
"3.2.0",
"3.3.0",
"3.4.0",
"3.5.0",
"3.6.0",
"3.6.1",
"3.6.2",
"3.7.0",
"3.7.1",
"3.7.2",
"3.7.3",
"3.8.0",
"3.8.1",
"3.9.0",
"4.0.0",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-4524
- https://github.com/roots/soil/pull/285
- https://github.com/roots/soil/commit/0c9151e00ab047da253e5cdbfccb204dd423269d
- https://github.com/roots/soil
- https://github.com/roots/soil/releases/tag/4.1.0
- https://github.com/roots/soil/releases/tag/4.1.1
- https://vuldb.com/?id.215904