GHSA-jrgf-vfw2-hj26high8.0
RCE via PHP Object injection via SOAP Requests
The advisory, in context
Impact
This vulnerability allows an admin user to generate soap credentials that can be used to trigger RCE via PHP Object Injection through product attributes and a product.
Patches
The latest OpenMage Versions up from 19.4.7 and 20.0.3 have this Issue solved
Credits
Credit to Luke Rodgers for reporting
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
openmage/magento-lts Packagist
Ecosystem versions
Earlier releases before 19.4.8
Fixed in 19.4.8
16 explicitly affected versions
1.9.1.1, 1.9.2.0, 1.9.2.1, 1.9.2.2, 1.9.2.3, 1.9.2.4, 1.9.3.0, 1.9.3.1, v19.4.0, v19.4.1, v19.4.2, v19.4.3, v19.4.4, v19.4.5, v19.4.6, v19.4.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "19.4.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.9.1.1",
"1.9.2.0",
"1.9.2.1",
"1.9.2.2",
"1.9.2.3",
"1.9.2.4",
"1.9.3.0",
"1.9.3.1",
"v19.4.0",
"v19.4.1",
"v19.4.2",
"v19.4.3",
"v19.4.4",
"v19.4.5",
"v19.4.6",
"v19.4.7"
]
}openmage/magento-lts Packagist
Ecosystem versions
From 20.0.0 before 20.0.4
Fixed in 20.0.4
4 explicitly affected versions
v20.0.0, v20.0.1, v20.0.2, v20.0.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "20.0.0"
},
{
"fixed": "20.0.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v20.0.0",
"v20.0.1",
"v20.0.2",
"v20.0.3"
]
}