GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-jqmq-fpwv-p925high7.5

DRUPAL-CONTRIB-2025-114

Check your stack

The advisory, in context

This module introduces an OAuth 2.0 authorization server, which can be configured to protect your Drupal instance with access tokens, or allow clients to request new access tokens and refresh them.

The module doesn't sufficiently respect granted scopes, it affects all access checks that are based on roles. For example: routes that have the _role requirement, can be bypassed with an access token.

This vulnerability is mitigated by the fact that an attacker must have the access token in possession and the user related to the token must have the associated (role requirement) roles assigned.

Update: the Affected versions field was updated to reflect that this vulnerability was present in the 6.0.0 release and fixed in 6.0.7. Earlier versions of this advisory incorrectly stated that other versions were affected.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 6.0.0 before 6.0.7

Fixed in 6.0.7

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "6.0.0"
        },
        {
          "fixed": "6.0.7"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": []
}
drupal/simple_oauth Packagist:https://packages.drupal.org/8
Ecosystem versions

From 6.0.0 before 6.0.7

Fixed in 6.0.7

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "6.0.0"
        },
        {
          "fixed": "6.0.7"
        }
      ],
      "type": "ECOSYSTEM",
      "database_specific": {
        "constraint": ">=6.0.0 <6.0.7"
      }
    }
  ],
  "versions": []
}

References