GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-jq9q-6p42-qpr7high

Cross-site Scripting (XSS) in DemoBundle/ezdemo bundled VideoJS

No CVE assignedCheck your stack

The advisory, in context

his Security Advisory is about a vulnerability in VideoJS, which is bundled in DemoBundle and the ezdemo legacy extension. Older releases of VideoJS contain an XSS vulnerability in the Flash-based video player. This is bundled in DemoBundle, and in the Legacy "ezdemo" and "ezdemo-ls-extension" extensions. Among the branches still receiving security advisories, only eZ Publish Platform 5.4 and eZ Publish Legacy 5.4 are affected. However, it may be possible to make this software work in newer branches, so please check whether you have it installed even if you're using eZ Platform 1.x or 2.x.

Because DemoBundle / ezdemo are only intended for demo purposes, they are not supported software. For that reason, and given the old age of the software, and manpower issues during the Coronavirus crisis, we are taking the unusual step of simply removing the affected file. This resolves the vulnerability, but also breaks the video playback feature. It may be possible to make it work again by upgrading to a current version of VideoJS, but it is unlikely that we will do this, given the reasons already mentioned.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 5.4.0 before 5.4.2.1

Fixed in 5.4.2.1

5 explicitly affected versions

v5.4.0, v5.4.1, v5.4.1-rc1, v5.4.2, v5.4.2-rc1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "5.4.0"
        },
        {
          "fixed": "5.4.2.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v5.4.0",
    "v5.4.1",
    "v5.4.1-rc1",
    "v5.4.2",
    "v5.4.2-rc1"
  ]
}

References