Drupal Denial of service via transliterate mechanism
The advisory, in context
The transliterate mechanism in Drupal 8.x before 8.2.3 allows remote attackers to cause a denial of service via a crafted URL.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 8.0 before 8.2.3
Fixed in 8.2.3
44 explicitly affected versions
8.0.0, 8.0.0-beta10, 8.0.0-beta11, 8.0.0-beta12, 8.0.0-beta13, 8.0.0-beta14, 8.0.0-beta15, 8.0.0-beta16, 8.0.0-beta6, 8.0.0-beta7, 8.0.0-beta8, 8.0.0-beta9, 8.0.0-rc1, 8.0.0-rc2, 8.0.0-rc3, 8.0.0-rc4, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.0-beta1, 8.1.0-beta2, 8.1.0-rc1, 8.1.1, 8.1.10, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.2.0, 8.2.0-beta1, 8.2.0-beta2, 8.2.0-beta3, 8.2.0-rc1, 8.2.0-rc2, 8.2.1, 8.2.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0"
},
{
"fixed": "8.2.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0.0",
"8.0.0-beta10",
"8.0.0-beta11",
"8.0.0-beta12",
"8.0.0-beta13",
"8.0.0-beta14",
"8.0.0-beta15",
"8.0.0-beta16",
"8.0.0-beta6",
"8.0.0-beta7",
"8.0.0-beta8",
"8.0.0-beta9",
"8.0.0-rc1",
"8.0.0-rc2",
"8.0.0-rc3",
"8.0.0-rc4",
"8.0.1",
"8.0.2",
"8.0.3",
"8.0.4",
"8.0.5",
"8.0.6",
"8.1.0",
"8.1.0-beta1",
"8.1.0-beta2",
"8.1.0-rc1",
"8.1.1",
"8.1.10",
"8.1.2",
"8.1.3",
"8.1.4",
"8.1.5",
"8.1.6",
"8.1.7",
"8.1.8",
"8.1.9",
"8.2.0",
"8.2.0-beta1",
"8.2.0-beta2",
"8.2.0-beta3",
"8.2.0-rc1",
"8.2.0-rc2",
"8.2.1",
"8.2.2"
]
}From 8.0 before 8.2.3
Fixed in 8.2.3
50 explicitly affected versions
8.0.0, 8.0.0-alpha14, 8.0.0-alpha15, 8.0.0-beta1, 8.0.0-beta10, 8.0.0-beta11, 8.0.0-beta12, 8.0.0-beta13, 8.0.0-beta14, 8.0.0-beta15, 8.0.0-beta16, 8.0.0-beta2, 8.0.0-beta3, 8.0.0-beta4, 8.0.0-beta5, 8.0.0-beta6, 8.0.0-beta7, 8.0.0-beta9, 8.0.0-rc1, 8.0.0-rc2, 8.0.0-rc3, 8.0.0-rc4, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.0-beta1, 8.1.0-beta2, 8.1.0-rc1, 8.1.1, 8.1.10, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.2.0, 8.2.0-beta1, 8.2.0-beta2, 8.2.0-beta3, 8.2.0-rc1, 8.2.0-rc2, 8.2.1, 8.2.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0"
},
{
"fixed": "8.2.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0.0",
"8.0.0-alpha14",
"8.0.0-alpha15",
"8.0.0-beta1",
"8.0.0-beta10",
"8.0.0-beta11",
"8.0.0-beta12",
"8.0.0-beta13",
"8.0.0-beta14",
"8.0.0-beta15",
"8.0.0-beta16",
"8.0.0-beta2",
"8.0.0-beta3",
"8.0.0-beta4",
"8.0.0-beta5",
"8.0.0-beta6",
"8.0.0-beta7",
"8.0.0-beta9",
"8.0.0-rc1",
"8.0.0-rc2",
"8.0.0-rc3",
"8.0.0-rc4",
"8.0.1",
"8.0.2",
"8.0.3",
"8.0.4",
"8.0.5",
"8.0.6",
"8.1.0",
"8.1.0-beta1",
"8.1.0-beta2",
"8.1.0-rc1",
"8.1.1",
"8.1.10",
"8.1.2",
"8.1.3",
"8.1.4",
"8.1.5",
"8.1.6",
"8.1.7",
"8.1.8",
"8.1.9",
"8.2.0",
"8.2.0-beta1",
"8.2.0-beta2",
"8.2.0-beta3",
"8.2.0-rc1",
"8.2.0-rc2",
"8.2.1",
"8.2.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-9452
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2016-9452.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2016-9452.yaml
- https://github.com/drupal/core
- https://www.drupal.org/SA-CORE-2016-005
- http://www.securityfocus.com/bid/94367