GHSA-jp4g-r8c9-3534critical10.0
Moodle Blind SSRF Risk in /badges/mybackpack.php
The advisory, in context
A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions. The mybackpack functionality allowed setting the URL of badges, when it should be restricted to the Mozilla Open Badges backpack URL. This resulted in the possibility of blind SSRF via requests made by the page.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.1 before 3.1.16
Fixed in 3.1.16
19 explicitly affected versions
v3.1.0, v3.1.0-beta, v3.1.0-rc1, v3.1.0-rc2, v3.1.1, v3.1.10, v3.1.11, v3.1.12, v3.1.13, v3.1.14, v3.1.15, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.1.8, v3.1.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.1"
},
{
"fixed": "3.1.16"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.1.0",
"v3.1.0-beta",
"v3.1.0-rc1",
"v3.1.0-rc2",
"v3.1.1",
"v3.1.10",
"v3.1.11",
"v3.1.12",
"v3.1.13",
"v3.1.14",
"v3.1.15",
"v3.1.2",
"v3.1.3",
"v3.1.4",
"v3.1.5",
"v3.1.6",
"v3.1.7",
"v3.1.8",
"v3.1.9"
]
}