baserCMS Cross-site Scripting vulnerability in Content Management
The advisory, in context
There is a XSS Vulnerability in Content Management Feature to baserCMS.
Target
baserCMS 5.0.8 and earlier versions
Vulnerability
Malicious code may be executed in Content Management Feature.
Countermeasures
Update to the latest version of baserCMS
Please refer to the following page to reference for more information. https://basercms.net/security/JVN_73283159
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 5.0.9
Fixed in 5.0.9
129 explicitly affected versions
0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.0.6, 0.0.7, 0.0.8, 1.0.0, 2.0.0-rc1, 2.0.0-rc2, 2.0.0-rc3, 2.0.0-rc4, 2.0.0-rc5, 2.0.0-rc6, 3.0.10, 3.0.10.1, 3.0.11, 3.0.11.1, 3.0.12, 3.0.13, 3.0.14, 3.0.15, 3.0.16, 3.0.17, 3.0.18, 3.0.19, 3.0.20, 3.0.21, 3.0.22, 3.0.23, 3.0.24, 3.0.25, 3.0.26, 3.0.7, 3.0.7.1, 3.0.8, 3.0.8.1, 3.0.9, 3.0.9.1, 4.0.0, 4.0.0-beta, 4.0.1, 4.0.10, 4.0.10.1, 4.0.11, 4.0.2, 4.0.2.1, 4.0.3, 4.0.4, 4.0.5, 4.0.5.1, 4.0.5.2, 4.0.6, 4.0.7, 4.0.8, 4.0.9, 4.1.0, 4.1.0.1, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.3.0, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 4.3.5, 4.3.6, 4.3.7, 4.3.7.1, 4.4.0, 4.4.1, 4.4.1.1, 4.4.2, 4.4.2.1, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.5.0, 4.5.1, 4.5.2, 4.5.3, 4.5.4, 4.5.5, 4.5.6, 4.6.0, 4.6.1, 4.6.1.1, 4.6.2, 4.6.3, 4.7.0, 4.7.2, 4.7.3, 4.7.5, 4.7.6, 4.7.7, 4.7.8, 4.8.0, 4.8.1, 4.8.2, 4.8.3, 5.0.0, 5.0.0-beta1, 5.0.0-beta2, 5.0.0-beta3, 5.0.0-beta4, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.0.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.0.1",
"0.0.2",
"0.0.3",
"0.0.4",
"0.0.5",
"0.0.6",
"0.0.7",
"0.0.8",
"1.0.0",
"2.0.0-rc1",
"2.0.0-rc2",
"2.0.0-rc3",
"2.0.0-rc4",
"2.0.0-rc5",
"2.0.0-rc6",
"3.0.10",
"3.0.10.1",
"3.0.11",
"3.0.11.1",
"3.0.12",
"3.0.13",
"3.0.14",
"3.0.15",
"3.0.16",
"3.0.17",
"3.0.18",
"3.0.19",
"3.0.20",
"3.0.21",
"3.0.22",
"3.0.23",
"3.0.24",
"3.0.25",
"3.0.26",
"3.0.7",
"3.0.7.1",
"3.0.8",
"3.0.8.1",
"3.0.9",
"3.0.9.1",
"4.0.0",
"4.0.0-beta",
"4.0.1",
"4.0.10",
"4.0.10.1",
"4.0.11",
"4.0.2",
"4.0.2.1",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.5.1",
"4.0.5.2",
"4.0.6",
"4.0.7",
"4.0.8",
"4.0.9",
"4.1.0",
"4.1.0.1",
"4.1.1",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.5",
"4.1.6",
"4.1.7",
"4.1.8",
"4.2.0",
"4.2.1",
"4.2.2",
"4.2.3",
"4.2.4",
"4.2.5",
"4.3.0",
"4.3.1",
"4.3.2",
"4.3.3",
"4.3.4",
"4.3.5",
"4.3.6",
"4.3.7",
"4.3.7.1",
"4.4.0",
"4.4.1",
"4.4.1.1",
"4.4.2",
"4.4.2.1",
"4.4.3",
"4.4.4",
"4.4.5",
"4.4.6",
"4.4.7",
"4.4.8",
"4.5.0",
"4.5.1",
"4.5.2",
"4.5.3",
"4.5.4",
"4.5.5",
"4.5.6",
"4.6.0",
"4.6.1",
"4.6.1.1",
"4.6.2",
"4.6.3",
"4.7.0",
"4.7.2",
"4.7.3",
"4.7.5",
"4.7.6",
"4.7.7",
"4.7.8",
"4.8.0",
"4.8.1",
"4.8.2",
"4.8.3",
"5.0.0",
"5.0.0-beta1",
"5.0.0-beta2",
"5.0.0-beta3",
"5.0.0-beta4",
"5.0.1",
"5.0.2",
"5.0.3",
"5.0.4",
"5.0.5",
"5.0.6",
"5.0.7",
"5.0.8"
]
}References
- https://github.com/baserproject/basercms/security/advisories/GHSA-jjxq-m8h3-4vw5
- https://nvd.nist.gov/vuln/detail/CVE-2024-26128
- https://github.com/baserproject/basercms/commit/18f426d63e752b4d22c40e9ea8d1f6e692ef601c
- https://basercms.net/security/JVN_73283159
- https://github.com/baserproject/basercms