GHSA-jj94-j4r3-5gr4medium6.1
Subrion Cross-Site Scripting (XSS) vulnerability
The advisory, in context
Cross-Site Scripting (XSS) vulnerability in Subrion 4.2.1 via the title when adding a page.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
intelliants/subrion Packagist
Ecosystem versions
From 4.2.1 before 4.2.2
Fixed in 4.2.2
2 explicitly affected versions
4.2.1, v4.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.1"
},
{
"fixed": "4.2.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.2.1",
"v4.2.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-22330
- https://github.com/intelliants/subrion/issues/850
- https://github.com/intelliants/subrion/commit/06950c2f9c4aa69e323cbdd141beabb6a9273ca4
- https://github.com/intelliants/subrion/commit/0e9180d2330a00b1ce8e7ec2e92e0a4e0612f1a9
- https://github.com/intelliants/subrion