GHSA-jj8r-p9f5-fmvvhigh8.5
Cross-site Scripting in TYPO3 extension
The advisory, in context
The miniorange_saml (aka Miniorange Saml) extension before 1.4.3 for TYPO3 allows XSS.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
miniorange/miniorange-saml Packagist
Ecosystem versions
Earlier releases before 1.4.3
Fixed in 1.4.3
10 explicitly affected versions
1.1.2, 1.2.0, 1.2.3, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.4.0, 1.4.1, 1.4.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.4.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.1.2",
"1.2.0",
"1.2.3",
"1.3.0",
"1.3.1",
"1.3.2",
"1.3.3",
"1.4.0",
"1.4.1",
"1.4.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2021-36785
- https://github.com/miniOrangeDev/miniorange-saml-typo3-sso/commit/1fe2802267ffe1b48823d9d8b3a496c870a0af48
- https://github.com/miniOrangeDev/miniorange-saml-typo3-sso
- https://typo3.org/help/security-advisories/security
- https://typo3.org/security/advisory/typo3-ext-sa-2021-011