GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-jj38-h5w5-mvpflow3.1

October CMS: Reflected XSS via DataTable Form Widget

Impact

A reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping.

Source excerpt · OSV
Applies when

Impact

  • Reflected XSS only, no stored/persistent component
  • The backend URL prefix is customizable and must be known or guessed by the attacker
  • Requires an authenticated backend user to visit a crafted URL
  • No direct access is gained without social engineering

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected rangeRecorded fix
Earlier releases before 3.7.16Ecosystem versions3.7.16
From 4.0.0; no upper bound recordedVersionsNot recorded

Version evidence: OSV · GHSA-jj38-h5w5-mvpf

View original version evidence (169 explicit versions)

Original source description

A reflected Cross-Site Scripting (XSS) vulnerability was identified in the backend DataTable widget where a query parameter was rendered without proper output escaping.

Impact

  • Reflected XSS only, no stored/persistent component
  • The backend URL prefix is customizable and must be known or guessed by the attacker
  • Requires an authenticated backend user to visit a crafted URL
  • No direct access is gained without social engineering

Patches

The vulnerability has been patched in v3.7.16 and v4.1.16. The affected parameter is now properly escaped. All users are encouraged to upgrade to the latest patched version.

Workarounds

  • Use a non-default backend URL prefix (recommended as standard practice)
  • Implement a Content Security Policy (CSP) for backend pages

References