GHSA-jhhf-c849-3rh2medium5.4
Comments plugin stored Cross-site Scripting via a guest name
The advisory, in context
An issue was discovered in the Comments plugin before 1.5.5 for Craft CMS. There is stored XSS via a guest name.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
verbb/comments Packagist
Ecosystem versions
Earlier releases before 1.5.5
Fixed in 1.5.5
52 explicitly affected versions
0.3.6, 0.3.8, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.6.1, 1.0.6.2, 1.0.6.3, 1.0.7, 1.0.7.1, 1.1.0, 1.1.1, 1.1.10, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.7.1, 1.1.8, 1.1.9, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.3.0, 1.3.1, 1.3.10, 1.3.11, 1.3.12, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 1.4.0, 1.4.1, 1.4.1.1, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.3.6",
"0.3.8",
"1.0.0",
"1.0.1",
"1.0.2",
"1.0.3",
"1.0.4",
"1.0.5",
"1.0.6",
"1.0.6.1",
"1.0.6.2",
"1.0.6.3",
"1.0.7",
"1.0.7.1",
"1.1.0",
"1.1.1",
"1.1.10",
"1.1.2",
"1.1.3",
"1.1.4",
"1.1.5",
"1.1.6",
"1.1.7",
"1.1.7.1",
"1.1.8",
"1.1.9",
"1.2.0",
"1.2.1",
"1.2.2",
"1.2.3",
"1.2.4",
"1.3.0",
"1.3.1",
"1.3.10",
"1.3.11",
"1.3.12",
"1.3.2",
"1.3.3",
"1.3.4",
"1.3.5",
"1.3.6",
"1.3.7",
"1.3.8",
"1.3.9",
"1.4.0",
"1.4.1",
"1.4.1.1",
"1.5.0",
"1.5.1",
"1.5.2",
"1.5.3",
"1.5.4"
]
}