GHSA-jfvf-rfmq-qwf8medium4.8
Croos-site scripting in Croogo
The advisory, in context
Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
croogo/croogo Packagist
Ecosystem versions
Earlier releases before 3.0.7
Fixed in 3.0.7
25 explicitly affected versions
2.3.3, 3.0.0, 3.0.0-alpha.1, 3.0.0-alpha.2, 3.0.0-alpha.3, 3.0.0-alpha.4, 3.0.0-beta.1, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, v2.0.0, v2.1.0, v2.1.1, v2.1.2, v2.2.0, v2.2.1, v2.2.2, v2.2.3, v2.2.4, v2.3.0, v2.3.1, v2.3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.3.3",
"3.0.0",
"3.0.0-alpha.1",
"3.0.0-alpha.2",
"3.0.0-alpha.3",
"3.0.0-alpha.4",
"3.0.0-beta.1",
"3.0.1",
"3.0.2",
"3.0.3",
"3.0.4",
"3.0.5",
"3.0.6",
"v2.0.0",
"v2.1.0",
"v2.1.1",
"v2.1.2",
"v2.2.0",
"v2.2.1",
"v2.2.2",
"v2.2.3",
"v2.2.4",
"v2.3.0",
"v2.3.1",
"v2.3.2"
]
}