GHSA-j99g-qjvx-995gcritical9.8
Contao Does Not Expire Tokens Correctly
The advisory, in context
Security researcher Ali Razzaq has discovered that confirming an opt-in token does not invalidate previous opt-in tokens in Contao 4.7.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
contao/contao Packagist
Ecosystem versions
From 4.7.0 before 4.7.3
Fixed in 4.7.3
3 explicitly affected versions
4.7.0, 4.7.1, 4.7.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7.0"
},
{
"fixed": "4.7.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.7.0",
"4.7.1",
"4.7.2"
]
}contao/core-bundle Packagist
Ecosystem versions
From 4.7.0 before 4.7.3
Fixed in 4.7.3
3 explicitly affected versions
4.7.0, 4.7.1, 4.7.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7.0"
},
{
"fixed": "4.7.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.7.0",
"4.7.1",
"4.7.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2019-10643
- https://github.com/contao/contao/commit/70348cc812b110831ad66a4f9857883f75649b88
- https://contao.org/en/news.html
- https://contao.org/en/news/security-vulnerability-cve-2019-10643.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2019-10643.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2019-10643.yaml