Silverstripe Form field validation message XSS vulnerability
The advisory, in context
A high level XSS risk has been identified in the encoding of validation messages in certain FormField classes.
Certain fields such as the NumericField and DropdownField have been identified, but any form field which presents any invalid content as a part of its validation response will be at risk.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.0.0 before 3.1.16
Fixed in 3.1.16
59 explicitly affected versions
3.0.10, 3.0.10-rc1, 3.0.11, 3.0.11-rc1, 3.0.12, 3.0.13, 3.0.14, 3.0.2.1, 3.0.3, 3.0.3-rc1, 3.0.3-rc2, 3.0.4, 3.0.5, 3.0.6, 3.0.6-rc1, 3.0.6-rc2, 3.0.7, 3.0.7-rc1, 3.0.8, 3.0.9, 3.0.9-rc1, 3.1.0, 3.1.0-beta1, 3.1.0-beta2, 3.1.0-beta3, 3.1.0-rc1, 3.1.0-rc2, 3.1.0-rc3, 3.1.1, 3.1.10, 3.1.10-rc1, 3.1.10-rc2, 3.1.11, 3.1.11-rc1, 3.1.12, 3.1.13, 3.1.13-rc1, 3.1.14, 3.1.14-rc1, 3.1.15, 3.1.16-rc1, 3.1.2, 3.1.2-rc1, 3.1.3, 3.1.3-rc1, 3.1.3-rc2, 3.1.4, 3.1.4-rc1, 3.1.5, 3.1.5-rc1, 3.1.6, 3.1.6-rc1, 3.1.6-rc2, 3.1.6-rc3, 3.1.7, 3.1.7-rc1, 3.1.8, 3.1.9, 3.1.9-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.1.16"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.10",
"3.0.10-rc1",
"3.0.11",
"3.0.11-rc1",
"3.0.12",
"3.0.13",
"3.0.14",
"3.0.2.1",
"3.0.3",
"3.0.3-rc1",
"3.0.3-rc2",
"3.0.4",
"3.0.5",
"3.0.6",
"3.0.6-rc1",
"3.0.6-rc2",
"3.0.7",
"3.0.7-rc1",
"3.0.8",
"3.0.9",
"3.0.9-rc1",
"3.1.0",
"3.1.0-beta1",
"3.1.0-beta2",
"3.1.0-beta3",
"3.1.0-rc1",
"3.1.0-rc2",
"3.1.0-rc3",
"3.1.1",
"3.1.10",
"3.1.10-rc1",
"3.1.10-rc2",
"3.1.11",
"3.1.11-rc1",
"3.1.12",
"3.1.13",
"3.1.13-rc1",
"3.1.14",
"3.1.14-rc1",
"3.1.15",
"3.1.16-rc1",
"3.1.2",
"3.1.2-rc1",
"3.1.3",
"3.1.3-rc1",
"3.1.3-rc2",
"3.1.4",
"3.1.4-rc1",
"3.1.5",
"3.1.5-rc1",
"3.1.6",
"3.1.6-rc1",
"3.1.6-rc2",
"3.1.6-rc3",
"3.1.7",
"3.1.7-rc1",
"3.1.8",
"3.1.9",
"3.1.9-rc1"
]
}From 3.2.0 before 3.2.1
Fixed in 3.2.1
3 explicitly affected versions
3.2.0, 3.2.1-rc1, 3.2.1-rc2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.2.0"
},
{
"fixed": "3.2.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.2.0",
"3.2.1-rc1",
"3.2.1-rc2"
]
}References
- https://github.com/silverstripe/silverstripe-framework/commit/245e0aae2f5f3eb0acba1d198ad8e196bb224462
- https://github.com/silverstripe/silverstripe-framework/commit/bc1b2893accba6401c03f9ea3b0cbc4621c7a02c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2015-026-1.yaml
- https://github.com/silverstripe/silverstripe-framework
- https://www.silverstripe.org/download/security-releases/ss-2015-026