Froxlor is vulnerable to authentication bypass
The advisory, in context
Authentication Bypass by Primary Weakness in GitHub repository froxlor/froxlor prior to 2.0.13.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.0.13
Fixed in 2.0.13
61 explicitly affected versions
0.10.0, 0.10.0-rc1, 0.10.0-rc2, 0.10.1, 0.10.10, 0.10.11, 0.10.12, 0.10.13, 0.10.14, 0.10.15, 0.10.16, 0.10.17, 0.10.18, 0.10.19, 0.10.2, 0.10.20, 0.10.21, 0.10.22, 0.10.23, 0.10.23.1, 0.10.24, 0.10.25, 0.10.26, 0.10.27, 0.10.28, 0.10.29, 0.10.29.1, 0.10.3, 0.10.30, 0.10.31, 0.10.32, 0.10.33, 0.10.34, 0.10.34.1, 0.10.35, 0.10.35.1, 0.10.36, 0.10.37, 0.10.38, 0.10.38.1, 0.10.38.2, 0.10.38.3, 0.10.4, 0.10.5, 0.10.6, 0.10.7, 0.10.8, 0.10.9, 2.0.0, 2.0.1, 2.0.10, 2.0.11, 2.0.12, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.10.0",
"0.10.0-rc1",
"0.10.0-rc2",
"0.10.1",
"0.10.10",
"0.10.11",
"0.10.12",
"0.10.13",
"0.10.14",
"0.10.15",
"0.10.16",
"0.10.17",
"0.10.18",
"0.10.19",
"0.10.2",
"0.10.20",
"0.10.21",
"0.10.22",
"0.10.23",
"0.10.23.1",
"0.10.24",
"0.10.25",
"0.10.26",
"0.10.27",
"0.10.28",
"0.10.29",
"0.10.29.1",
"0.10.3",
"0.10.30",
"0.10.31",
"0.10.32",
"0.10.33",
"0.10.34",
"0.10.34.1",
"0.10.35",
"0.10.35.1",
"0.10.36",
"0.10.37",
"0.10.38",
"0.10.38.1",
"0.10.38.2",
"0.10.38.3",
"0.10.4",
"0.10.5",
"0.10.6",
"0.10.7",
"0.10.8",
"0.10.9",
"2.0.0",
"2.0.1",
"2.0.10",
"2.0.11",
"2.0.12",
"2.0.2",
"2.0.3",
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.7",
"2.0.8",
"2.0.9"
]
}