GHSA-j2hg-w4p4-6rvmmedium5.3
EC-CUBE vulnerable to authorization bypass
The advisory, in context
Authorization bypass through user-controlled key issue exists in EC-CUBE 2.11.0 through 2.12.2 and EC-Orange systems deployed before June 29th, 2015. If this vulnerability is exploited, a user of the affected shopping website may obtain other users' information by sending a crafted HTTP request.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
ec-cube/ec-cube Packagist
Ecosystem versions
From 2.11.0 before 2.12.2
Fixed in 2.12.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.11.0"
},
{
"fixed": "2.12.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-0808
- https://github.com/EC-CUBE/ec-cube
- https://jvn.jp/en/jp/JVN15637138
- https://jvndb.jvn.jp/jvndb/JVNDB-2024-000054
- http://jvn.jp/en/jp/JVN51770585
- http://jvn.jp/en/jp/JVN51770585/index.html
- http://jvndb.jvn.jp/jvndb/JVNDB-2014-000006
- http://www.ec-cube.net/info/weakness/weakness.php?id=57