GHSA-hwq7-cvp8-6hm3medium6.1
phpBB Open Redirect
The advisory, in context
Open redirect vulnerability in phpBB before 3.0.14 and 3.1.x before 3.1.4 allows remote attackers to redirect users of Google Chrome to arbitrary web sites and conduct phishing attacks via unspecified vectors.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpbb/phpbb Packagist
Ecosystem versions
Earlier releases before 3.0.14
Fixed in 3.0.14
8 explicitly affected versions
3.0.12, 3.0.12-RC1, 3.0.12-RC2, 3.0.12-RC3, 3.0.13, 3.0.13-PL1, 3.0.13-RC1, 3.0.14-RC1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.12",
"3.0.12-RC1",
"3.0.12-RC2",
"3.0.12-RC3",
"3.0.13",
"3.0.13-PL1",
"3.0.13-RC1",
"3.0.14-RC1"
]
}phpbb/phpbb Packagist
Ecosystem versions
From 3.1.0 before 3.1.4
Fixed in 3.1.4
9 explicitly affected versions
3.1.0, 3.1.1, 3.1.2, 3.1.2-RC1, 3.1.3, 3.1.3-RC1, 3.1.3-RC2, 3.1.4-RC1, 3.1.4-RC2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.1.0"
},
{
"fixed": "3.1.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.1.0",
"3.1.1",
"3.1.2",
"3.1.2-RC1",
"3.1.3",
"3.1.3-RC1",
"3.1.3-RC2",
"3.1.4-RC1",
"3.1.4-RC2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-3880
- https://github.com/phpbb/phpbb/commit/1a3350619f428d9d69d196c52128727e27ef2f04
- https://github.com/phpbb/phpbb/commit/c1702b8e19a69c98ef049abb4e14157e3e208ed4
- https://github.com/phpbb/phpbb
- https://web.archive.org/web/20170520103544/http://www.securityfocus.com/bid/74592
- https://wiki.phpbb.com/Release_Highlights/3.0.14
- https://wiki.phpbb.com/Release_Highlights/3.1.4
- https://www.phpbb.com/community/viewtopic.php?f=14&t=2313941
- http://www.openwall.com/lists/oss-security/2015/05/12/10