GHSA-hvpq-7vcc-5hj5medium5.4
Froala Editor Cross-site Scripting vulnerability
The advisory, in context
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
froala/wysiwyg-editor Packagist
Ecosystem versions
From 4.0.1 before 4.1.4
Fixed in 4.1.4
23 explicitly affected versions
v4.0.1, v4.0.10, v4.0.11, v4.0.12, v4.0.13, v4.0.14, v4.0.15, v4.0.16, v4.0.17, v4.0.18, v4.0.19, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.2, v4.1.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.1"
},
{
"fixed": "4.1.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.0.1",
"v4.0.10",
"v4.0.11",
"v4.0.12",
"v4.0.13",
"v4.0.14",
"v4.0.15",
"v4.0.16",
"v4.0.17",
"v4.0.18",
"v4.0.19",
"v4.0.2",
"v4.0.3",
"v4.0.4",
"v4.0.5",
"v4.0.6",
"v4.0.7",
"v4.0.8",
"v4.0.9",
"v4.1.0",
"v4.1.1",
"v4.1.2",
"v4.1.3"
]
}froala-editor npm
Semantic versions
From 4.0.1 before 4.1.4
Fixed in 4.1.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.1"
},
{
"fixed": "4.1.4"
}
],
"type": "SEMVER"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-41592
- https://github.com/froala/wysiwyg-editor/issues/4612#issuecomment-1729818089
- https://froala.com/wysiwyg-editor/changelog/#4.1.4
- https://github.com/froala/wysiwyg-editor
- https://hacker.soarescorp.com/cve/2023-41592
- https://owasp.org/Top10/A03_2021-Injection
- https://owasp.org/www-project-top-ten