PrestaShop eval injection possible if shop vulnerable to SQL injection
The advisory, in context
Impact
Eval injection possible if the shop is vulnerable to an SQL injection.
Patches
The problem is fixed in version 1.7.8.7
Workarounds
Delete the MySQL Smarty cache feature by removing these lines in the file config/smarty.config.inc.php lines 43-46 (PrestaShop 1.7) or 40-43 (PrestaShop 1.6):
if (Configuration::get('PS_SMARTY_CACHING_TYPE') == 'mysql') {
include _PS_CLASS_DIR_.'Smarty/SmartyCacheResourceMysql.php';
$smarty->caching_type = 'mysql';
}
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.6.0.10 before 1.7.8.7
Fixed in 1.7.8.7
74 explicitly affected versions
1.7.0.0, 1.7.0.0-beta.1.0, 1.7.0.0-beta.2.0, 1.7.0.0-beta.3.0, 1.7.0.0-beta.4.0, 1.7.0.0-rc.0.0, 1.7.0.0-rc.1.0, 1.7.0.0-rc.2.0, 1.7.0.1, 1.7.0.2, 1.7.0.3, 1.7.0.4, 1.7.0.5, 1.7.0.6, 1.7.1.0, 1.7.1.1, 1.7.1.2, 1.7.2.0, 1.7.2.0-rc.1.0, 1.7.2.1, 1.7.2.2, 1.7.2.3, 1.7.2.4, 1.7.2.5, 1.7.3.0, 1.7.3.1, 1.7.3.2, 1.7.3.3, 1.7.3.4, 1.7.4.0, 1.7.4.0-beta.1, 1.7.4.1, 1.7.4.2, 1.7.4.3, 1.7.4.4, 1.7.5.0, 1.7.5.0-beta.1, 1.7.5.0-rc.1, 1.7.5.1, 1.7.5.2, 1.7.6.0, 1.7.6.0-beta.1, 1.7.6.0-rc.1, 1.7.6.0-rc.2, 1.7.6.1, 1.7.6.2, 1.7.6.3, 1.7.6.4, 1.7.6.5, 1.7.6.6, 1.7.6.7, 1.7.6.8, 1.7.6.9, 1.7.7.0, 1.7.7.0-beta.1, 1.7.7.0-beta.2, 1.7.7.0-rc.1, 1.7.7.1, 1.7.7.2, 1.7.7.3, 1.7.7.4, 1.7.7.5, 1.7.7.6, 1.7.7.7, 1.7.7.8, 1.7.8.0, 1.7.8.0-beta.1, 1.7.8.0-rc.1, 1.7.8.1, 1.7.8.2, 1.7.8.3, 1.7.8.4, 1.7.8.5, 1.7.8.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.6.0.10"
},
{
"fixed": "1.7.8.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.7.0.0",
"1.7.0.0-beta.1.0",
"1.7.0.0-beta.2.0",
"1.7.0.0-beta.3.0",
"1.7.0.0-beta.4.0",
"1.7.0.0-rc.0.0",
"1.7.0.0-rc.1.0",
"1.7.0.0-rc.2.0",
"1.7.0.1",
"1.7.0.2",
"1.7.0.3",
"1.7.0.4",
"1.7.0.5",
"1.7.0.6",
"1.7.1.0",
"1.7.1.1",
"1.7.1.2",
"1.7.2.0",
"1.7.2.0-rc.1.0",
"1.7.2.1",
"1.7.2.2",
"1.7.2.3",
"1.7.2.4",
"1.7.2.5",
"1.7.3.0",
"1.7.3.1",
"1.7.3.2",
"1.7.3.3",
"1.7.3.4",
"1.7.4.0",
"1.7.4.0-beta.1",
"1.7.4.1",
"1.7.4.2",
"1.7.4.3",
"1.7.4.4",
"1.7.5.0",
"1.7.5.0-beta.1",
"1.7.5.0-rc.1",
"1.7.5.1",
"1.7.5.2",
"1.7.6.0",
"1.7.6.0-beta.1",
"1.7.6.0-rc.1",
"1.7.6.0-rc.2",
"1.7.6.1",
"1.7.6.2",
"1.7.6.3",
"1.7.6.4",
"1.7.6.5",
"1.7.6.6",
"1.7.6.7",
"1.7.6.8",
"1.7.6.9",
"1.7.7.0",
"1.7.7.0-beta.1",
"1.7.7.0-beta.2",
"1.7.7.0-rc.1",
"1.7.7.1",
"1.7.7.2",
"1.7.7.3",
"1.7.7.4",
"1.7.7.5",
"1.7.7.6",
"1.7.7.7",
"1.7.7.8",
"1.7.8.0",
"1.7.8.0-beta.1",
"1.7.8.0-rc.1",
"1.7.8.1",
"1.7.8.2",
"1.7.8.3",
"1.7.8.4",
"1.7.8.5",
"1.7.8.6"
]
}References
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-hrgx-p36p-89q4
- https://nvd.nist.gov/vuln/detail/CVE-2022-31181
- https://github.com/PrestaShop/PrestaShop/commit/b6d96e7c2a4e35a44e96ffbcdfd34439b56af804
- https://github.com/PrestaShop/PrestaShop
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.8.7