Pimcore includes vulnerable PHPOffice/PhpSpreadsheet
Impact
Pimcore 10.6.x and Enterprise 10.6.x versions currently depend on PHPOffice/PhpSpreadsheet version 1.x, which has recently been identified with a security vulnerability (CVE-2024-45048). To mitigate this issue, it is recommended to update to the latest version 2.2.2. For more details, please refer to the official advisory: GHSA-ghg6-32f9-2jp7.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| Earlier releases before 1.8.9Ecosystem versions | 1.8.9 |
| From 1.9.0 before 1.9.3Ecosystem versions | 1.9.3 |
Version evidence: OSV · GHSA-hq76-662x-7mw4
View original version evidence (53 explicit versions)
| Affected range | Recorded fix |
|---|---|
| Earlier releases before 1.3.11Ecosystem versions | 1.3.11 |
| From 1.4.0 before 1.4.7Ecosystem versions | 1.4.7 |
| From 1.5.0 before 1.5.4Ecosystem versions | 1.5.4 |
Version evidence: OSV · GHSA-hq76-662x-7mw4
View original version evidence (38 explicit versions)
| Affected range | Recorded fix |
|---|---|
| From 10.6.9.0 before 10.6.9.12Ecosystem versions | 10.6.9.12 |
| From 11.1.0.0 before 11.1.6.11Ecosystem versions | 11.1.6.11 |
Version evidence: OSV · GHSA-hq76-662x-7mw4
View original version evidence (6 explicit versions)
Original source description
Summary
Pimcore 10.6.x and Enterprise 10.6.x versions currently depend on PHPOffice/PhpSpreadsheet version 1.x, which has recently been identified with a security vulnerability (CVE-2024-45048). To mitigate this issue, it is recommended to update to the latest version 2.2.2. For more details, please refer to the official advisory: GHSA-ghg6-32f9-2jp7.