Cross-Site Scripting (XSS) in TYPO3 Backend
The advisory, in context
Failing to properly encode user input, the page module is vulnerable to Cross-Site Scripting. A valid backend user account with permissions to edit plugins is needed to exploit this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 6.2.0 before 6.2.27
Fixed in 6.2.27
28 explicitly affected versions
6.2.0, 6.2.1, 6.2.10, 6.2.10-rc1, 6.2.11, 6.2.12, 6.2.13, 6.2.14, 6.2.15, 6.2.16, 6.2.17, 6.2.18, 6.2.19, 6.2.2, 6.2.20, 6.2.21, 6.2.22, 6.2.23, 6.2.24, 6.2.25, 6.2.26, 6.2.3, 6.2.4, 6.2.5, 6.2.6, 6.2.7, 6.2.8, 6.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.2.0"
},
{
"fixed": "6.2.27"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.2.0",
"6.2.1",
"6.2.10",
"6.2.10-rc1",
"6.2.11",
"6.2.12",
"6.2.13",
"6.2.14",
"6.2.15",
"6.2.16",
"6.2.17",
"6.2.18",
"6.2.19",
"6.2.2",
"6.2.20",
"6.2.21",
"6.2.22",
"6.2.23",
"6.2.24",
"6.2.25",
"6.2.26",
"6.2.3",
"6.2.4",
"6.2.5",
"6.2.6",
"6.2.7",
"6.2.8",
"6.2.9"
]
}From 7.6.0 before 7.6.11
Fixed in 7.6.11
11 explicitly affected versions
7.6.0, 7.6.1, 7.6.10, 7.6.2, 7.6.3, 7.6.4, 7.6.5, 7.6.6, 7.6.7, 7.6.8, 7.6.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.6.0"
},
{
"fixed": "7.6.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.6.0",
"7.6.1",
"7.6.10",
"7.6.2",
"7.6.3",
"7.6.4",
"7.6.5",
"7.6.6",
"7.6.7",
"7.6.8",
"7.6.9"
]
}From 8.0.0 before 8.3.1
Fixed in 8.3.1
8 explicitly affected versions
8.0.0, 8.0.1, 8.1.0, 8.1.1, 8.1.2, 8.2.0, 8.2.1, 8.3.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.3.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0.0",
"8.0.1",
"8.1.0",
"8.1.1",
"8.1.2",
"8.2.0",
"8.2.1",
"8.3.0"
]
}