GHSA-hj95-mhgf-jxc4critical9.8
ExecuTorch integer overflow vulnerability
The advisory, in context
An integer overflow vulnerability in the loading of ExecuTorch models can cause overlapping allocations, potentially resulting in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit d158236b1dc84539c1b16843bc74054c9dcba006.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
executorch PyPI
Ecosystem versions
Earlier releases before 0.7.0
Fixed in 0.7.0
8 explicitly affected versions
0.1.0, 0.1.2, 0.2.0, 0.2.1, 0.3.0, 0.4.0, 0.5.0, 0.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.0",
"0.1.2",
"0.2.0",
"0.2.1",
"0.3.0",
"0.4.0",
"0.5.0",
"0.6.0"
]
}Ecosystem versions
Earlier releases before 0.7.0
Fixed in 0.7.0
10 explicitly affected versions
0.5.0, 0.5.1, 0.6.0, 0.6.0-rc1, 0.6.0-rc3, 0.6.0-rc4, 0.6.0-rc6, 0.7.0-rc1, 0.7.0-rc2, 0.7.0-rc5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.5.0",
"0.5.1",
"0.6.0",
"0.6.0-rc1",
"0.6.0-rc3",
"0.6.0-rc4",
"0.6.0-rc6",
"0.7.0-rc1",
"0.7.0-rc2",
"0.7.0-rc5"
]
}github.com/pytorch/executorch SwiftURL
Semantic versions
Earlier releases before 0.7.0
Fixed in 0.7.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.0"
}
],
"type": "SEMVER"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-30404
- https://github.com/pytorch/executorch/commit/d158236b1dc84539c1b16843bc74054c9dcba006
- https://github.com/pypa/advisory-database/tree/main/vulns/executorch/PYSEC-2026-335.yaml
- https://github.com/pytorch/executorch
- https://pypi.org/project/executorch
- https://www.facebook.com/security/advisories/cve-2025-30404