Cross-site Scripting in Semantic MediaWiki
The advisory, in context
Special:Ask in Semantic MediaWiki before 4.0.2 allows Reflected XSS.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 4.0.2
Fixed in 4.0.2
64 explicitly affected versions
1.9, 1.9-RC1, 1.9.0.1, 1.9.0.2, 1.9.1, 1.9.1.1, 1.9.2, 1.9beta1, 2.0, 2.0-RC1, 2.0-RC2, 2.0-RC3, 2.1.0, 2.1.0-RC1, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.0-RC1, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.0-RC1, 2.3.1, 2.4.0, 2.4.0-RC1, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.0-rc.1, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5, 2.5.6, 2.5.7, 2.5.8, 3.0.0, 3.0.0-rc.1, 3.0.0-rc.2, 3.0.1, 3.0.2, 3.1.0, 3.1.0-rc.1, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.2.0, 3.2.0-rc.1, 3.2.0-rc.2, 3.2.1, 3.2.2, 3.2.3, 4.0.0, 4.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.9",
"1.9-RC1",
"1.9.0.1",
"1.9.0.2",
"1.9.1",
"1.9.1.1",
"1.9.2",
"1.9beta1",
"2.0",
"2.0-RC1",
"2.0-RC2",
"2.0-RC3",
"2.1.0",
"2.1.0-RC1",
"2.1.1",
"2.1.2",
"2.1.3",
"2.2.0",
"2.2.0-RC1",
"2.2.1",
"2.2.2",
"2.2.3",
"2.3.0",
"2.3.0-RC1",
"2.3.1",
"2.4.0",
"2.4.0-RC1",
"2.4.1",
"2.4.2",
"2.4.3",
"2.4.4",
"2.4.5",
"2.4.6",
"2.5.0",
"2.5.0-rc.1",
"2.5.1",
"2.5.2",
"2.5.3",
"2.5.4",
"2.5.5",
"2.5.6",
"2.5.7",
"2.5.8",
"3.0.0",
"3.0.0-rc.1",
"3.0.0-rc.2",
"3.0.1",
"3.0.2",
"3.1.0",
"3.1.0-rc.1",
"3.1.1",
"3.1.2",
"3.1.3",
"3.1.4",
"3.1.5",
"3.1.6",
"3.2.0",
"3.2.0-rc.1",
"3.2.0-rc.2",
"3.2.1",
"3.2.2",
"3.2.3",
"4.0.0",
"4.0.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-48614
- https://github.com/SemanticMediaWiki/SemanticMediaWiki/issues/5262
- https://github.com/SemanticMediaWiki/SemanticMediaWiki/commit/604968d44fcdfcbb7f1e00c5d662ca5d5a3a5613
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/semantic-media-wiki/CVE-2022-48614.yaml
- https://github.com/SemanticMediaWiki/SemanticMediaWiki
- https://www.semantic-mediawiki.org/wiki/Semantic_MediaWiki_4.0.2