GHSA-hhxf-w8hj-43w6low1.3
Moodle vulnerable to Cross-site Scripting
The advisory, in context
Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 1.8.0 before 1.8.12
Fixed in 1.8.12
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.8.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}moodle/moodle Packagist
Ecosystem versions
From 1.9.0 before 1.9.8
Fixed in 1.9.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.9.0"
},
{
"fixed": "1.9.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}