GHSA-hhvj-mcrx-3vcfmedium6.1
silverstripe/framework has Cross-site Scripting vulnerability in page name
No CVE assignedCheck your stack
The advisory, in context
silverstripe/framework is vulnerable to XSS in Page name where the payload "><svg/onload=alert(/xss/)> will trigger an XSS alert.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
silverstripe/framework Packagist
Ecosystem versions
From 3.4.0-rc1 before 3.4.4
Fixed in 3.4.4
9 explicitly affected versions
3.4.0, 3.4.0-rc1, 3.4.1, 3.4.1-rc1, 3.4.1-rc2, 3.4.2, 3.4.3, 3.4.3-rc1, 3.4.4-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.4.0-rc1"
},
{
"fixed": "3.4.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.4.0",
"3.4.0-rc1",
"3.4.1",
"3.4.1-rc1",
"3.4.1-rc2",
"3.4.2",
"3.4.3",
"3.4.3-rc1",
"3.4.4-rc1"
]
}silverstripe/framework Packagist
Ecosystem versions
From 3.5.0-rc1 before 3.5.2
Fixed in 3.5.2
8 explicitly affected versions
3.5.0, 3.5.0-rc1, 3.5.0-rc2, 3.5.0-rc3, 3.5.1, 3.5.1-rc1, 3.5.1-rc2, 3.5.2-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5.0-rc1"
},
{
"fixed": "3.5.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.5.0",
"3.5.0-rc1",
"3.5.0-rc2",
"3.5.0-rc3",
"3.5.1",
"3.5.1-rc1",
"3.5.1-rc2",
"3.5.2-rc1"
]
}References
- https://github.com/silverstripe/silverstripe-framework/commit/9574d627f95aca7ae0fcefcae2bf56215777e190
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2017-001-1.yaml
- https://github.com/silverstripe/silverstripe-framework
- https://www.silverstripe.org/download/security-releases/ss-2017-001