Yii SQL injection vulnerability
The advisory, in context
The findByCondition function in framework/db/ActiveRecord.php in Yii 2.x before 2.0.15 allows remote attackers to conduct SQL injection attacks via a findOne() or findAll() call, unless a developer recognizes an undocumented need to sanitize array input.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.0.12.1
Fixed in 2.0.12.1
18 explicitly affected versions
2.0.0, 2.0.0-alpha, 2.0.0-beta, 2.0.0-rc, 2.0.1, 2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.12, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.12.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.0-alpha",
"2.0.0-beta",
"2.0.0-rc",
"2.0.1",
"2.0.10",
"2.0.11",
"2.0.11.1",
"2.0.11.2",
"2.0.12",
"2.0.2",
"2.0.3",
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.7",
"2.0.8",
"2.0.9"
]
}From 2.0.13 before 2.0.13.2
Fixed in 2.0.13.2
2 explicitly affected versions
2.0.13, 2.0.13.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.13"
},
{
"fixed": "2.0.13.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.13",
"2.0.13.1"
]
}From 2.0.14 before 2.0.15
Fixed in 2.0.15
3 explicitly affected versions
2.0.14, 2.0.14.1, 2.0.14.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.14"
},
{
"fixed": "2.0.15"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.14",
"2.0.14.1",
"2.0.14.2"
]
}