Apache Airflow Hive Provider Beeline remote code execution with Principal
The advisory, in context
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Hive Provider. This issue affects Apache Airflow Apache Hive Provider: before 6.1.1.
Before version 6.1.1 it was possible to bypass the security check to RCE via principal parameter. For this to be exploited it requires access to modifying the connection details.
It is recommended updating provider version to 6.1.1 in order to avoid this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 6.1.1
Fixed in 6.1.1
66 explicitly affected versions
1.0.0, 1.0.0b1, 1.0.0b2, 1.0.0rc1, 1.0.1, 1.0.1rc1, 1.0.2, 1.0.2rc1, 1.0.3, 1.0.3rc1, 2.0.0, 2.0.0rc1, 2.0.0rc2, 2.0.1, 2.0.1rc1, 2.0.1rc2, 2.0.2, 2.0.2rc1, 2.0.3, 2.0.3rc1, 2.1.0, 2.1.0rc1, 2.2.0, 2.2.0rc1, 2.2.0rc2, 2.3.0, 2.3.0rc1, 2.3.1, 2.3.1rc1, 2.3.2, 2.3.2rc1, 2.3.3, 2.3.3rc1, 3.0.0, 3.0.0rc1, 3.0.0rc2, 3.1.0, 3.1.0rc1, 4.0.0, 4.0.0rc1, 4.0.0rc2, 4.0.0rc3, 4.0.1, 4.0.1rc1, 4.1.0, 4.1.0rc1, 4.1.1, 4.1.1rc2, 4.1.1rc3, 5.0.0, 5.0.0rc1, 5.1.0, 5.1.0rc1, 5.1.0rc2, 5.1.1, 5.1.1rc1, 5.1.2, 5.1.2rc1, 5.1.3, 5.1.3rc1, 6.0.0, 6.0.0rc1, 6.1.0, 6.1.0rc1, 6.1.0rc2, 6.1.1rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "6.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.0b1",
"1.0.0b2",
"1.0.0rc1",
"1.0.1",
"1.0.1rc1",
"1.0.2",
"1.0.2rc1",
"1.0.3",
"1.0.3rc1",
"2.0.0",
"2.0.0rc1",
"2.0.0rc2",
"2.0.1",
"2.0.1rc1",
"2.0.1rc2",
"2.0.2",
"2.0.2rc1",
"2.0.3",
"2.0.3rc1",
"2.1.0",
"2.1.0rc1",
"2.2.0",
"2.2.0rc1",
"2.2.0rc2",
"2.3.0",
"2.3.0rc1",
"2.3.1",
"2.3.1rc1",
"2.3.2",
"2.3.2rc1",
"2.3.3",
"2.3.3rc1",
"3.0.0",
"3.0.0rc1",
"3.0.0rc2",
"3.1.0",
"3.1.0rc1",
"4.0.0",
"4.0.0rc1",
"4.0.0rc2",
"4.0.0rc3",
"4.0.1",
"4.0.1rc1",
"4.1.0",
"4.1.0rc1",
"4.1.1",
"4.1.1rc2",
"4.1.1rc3",
"5.0.0",
"5.0.0rc1",
"5.1.0",
"5.1.0rc1",
"5.1.0rc2",
"5.1.1",
"5.1.1rc1",
"5.1.2",
"5.1.2rc1",
"5.1.3",
"5.1.3rc1",
"6.0.0",
"6.0.0rc1",
"6.1.0",
"6.1.0rc1",
"6.1.0rc2",
"6.1.1rc1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-35797
- https://github.com/apache/airflow/pull/31983
- https://github.com/apache/airflow/commit/6724eeb6210d5965937eaf9dae3e476eb30f8268
- https://github.com/apache/airflow
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-apache-hive/PYSEC-2026-273.yaml
- https://lists.apache.org/thread/30y19ok07fw52x5hnkbhwqo3ho0wwc1y
- https://pypi.org/project/apache-airflow-providers-apache-hive
- http://www.openwall.com/lists/oss-security/2023/07/12/3