MediaWiki Cross-site Scripting (XSS) vulnerability
The advisory, in context
An issue was discovered in MediaWiki before 1.31.9 and 1.32.x through 1.34.x before 1.34.3. The non-jqueryMsg version of mw.message().parse() doesn't escape HTML. This affects both message contents (which are generally safe) and the parameters (which can be based on user input). (When jqueryMsg is loaded, it correctly accepts only whitelisted tags in message contents, and escapes all parameters. Situations with an unloaded jqueryMsg are rare in practice, but can for example occur for Special:SpecialPages on a wiki with no extensions installed.)
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.31.0 before 1.31.9
Fixed in 1.31.9
9 explicitly affected versions
1.31.0, 1.31.1, 1.31.2, 1.31.3, 1.31.4, 1.31.5, 1.31.6, 1.31.7, 1.31.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.31.0"
},
{
"fixed": "1.31.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.31.0",
"1.31.1",
"1.31.2",
"1.31.3",
"1.31.4",
"1.31.5",
"1.31.6",
"1.31.7",
"1.31.8"
]
}From 1.32.0 before 1.34.3
Fixed in 1.34.3
18 explicitly affected versions
1.32.0, 1.32.1, 1.32.2, 1.32.3, 1.32.4, 1.32.5, 1.32.6, 1.33.0, 1.33.0-rc.0, 1.33.1, 1.33.2, 1.33.3, 1.33.4, 1.34.0, 1.34.0-rc.0, 1.34.0-rc.1, 1.34.1, 1.34.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.32.0"
},
{
"fixed": "1.34.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.32.0",
"1.32.1",
"1.32.2",
"1.32.3",
"1.32.4",
"1.32.5",
"1.32.6",
"1.33.0",
"1.33.0-rc.0",
"1.33.1",
"1.33.2",
"1.33.3",
"1.33.4",
"1.34.0",
"1.34.0-rc.0",
"1.34.0-rc.1",
"1.34.1",
"1.34.2"
]
}From 1.35.0-rc.0 before 1.35.0
Fixed in 1.35.0
4 explicitly affected versions
1.35.0-rc.0, 1.35.0-rc.1, 1.35.0-rc.2, 1.35.0-rc.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.35.0-rc.0"
},
{
"fixed": "1.35.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.35.0-rc.0",
"1.35.0-rc.1",
"1.35.0-rc.2",
"1.35.0-rc.3"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-25828
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2020-25828.yaml
- https://github.com/wikimedia/mediawiki
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RTTPZ7XMDS66I442OLLHXBDNP2LCBJU6
- https://lists.wikimedia.org/pipermail/mediawiki-announce
- https://lists.wikimedia.org/pipermail/mediawiki-l/2020-September/048480.html
- https://lists.wikimedia.org/pipermail/mediawiki-l/2020-September/048488.html
- https://phabricator.wikimedia.org/T115888