nZEDb Cross-site Scripting (XSS) in the 404 error page
The advisory, in context
nZEDb before 0.8.0.0 has XSS in the 404 error page.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 0.8.0.0
Fixed in 0.8.0.0
57 explicitly affected versions
v0.6.0, v0.6.0-RC1, v0.6.0-RC2, v0.6.0-RC3, v0.6.0-RC4, v0.6.0-RC5, v0.6.0-RC6, v0.6.0.1, v0.6.0.2, v0.6.1, v0.6.1-RC1, v0.6.1.1, v0.6.1.2, v0.6.1.3, v0.6.2, v0.6.2-RC1, v0.6.2-RC2, v0.6.2.1, v0.6.2.2, v0.6.2.3, v0.6.2.4, v0.6.3, v0.6.3-RC1, v0.6.3.1, v0.6.3.2, v0.6.3.2-RC1, v0.6.3.3, v0.6.3.3-RC1, v0.6.4.0, v0.6.4.0-RC1, v0.6.4.1, v0.6.4.1-RC1, v0.6.5.0, v0.6.5.0-RC1, v0.6.5.1, v0.6.5.2, v0.6.5.2-RC1, v0.6.5.3, v0.6.6.0, v0.6.6.1, v0.6.6.2, v0.6.7.0, v0.6.8.0, v0.6.8.1, v0.6.9.0, v0.7.0.0, v0.7.1.0, v0.7.1.1, v0.7.1.2, v0.7.2.0, v0.7.2.1, v0.7.3.0, v0.7.3.1, v0.7.3.2, v0.7.3.3, v0.7.4.0, v0.7.4.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.6.0",
"v0.6.0-RC1",
"v0.6.0-RC2",
"v0.6.0-RC3",
"v0.6.0-RC4",
"v0.6.0-RC5",
"v0.6.0-RC6",
"v0.6.0.1",
"v0.6.0.2",
"v0.6.1",
"v0.6.1-RC1",
"v0.6.1.1",
"v0.6.1.2",
"v0.6.1.3",
"v0.6.2",
"v0.6.2-RC1",
"v0.6.2-RC2",
"v0.6.2.1",
"v0.6.2.2",
"v0.6.2.3",
"v0.6.2.4",
"v0.6.3",
"v0.6.3-RC1",
"v0.6.3.1",
"v0.6.3.2",
"v0.6.3.2-RC1",
"v0.6.3.3",
"v0.6.3.3-RC1",
"v0.6.4.0",
"v0.6.4.0-RC1",
"v0.6.4.1",
"v0.6.4.1-RC1",
"v0.6.5.0",
"v0.6.5.0-RC1",
"v0.6.5.1",
"v0.6.5.2",
"v0.6.5.2-RC1",
"v0.6.5.3",
"v0.6.6.0",
"v0.6.6.1",
"v0.6.6.2",
"v0.6.7.0",
"v0.6.8.0",
"v0.6.8.1",
"v0.6.9.0",
"v0.7.0.0",
"v0.7.1.0",
"v0.7.1.1",
"v0.7.1.2",
"v0.7.2.0",
"v0.7.2.1",
"v0.7.3.0",
"v0.7.3.1",
"v0.7.3.2",
"v0.7.3.3",
"v0.7.4.0",
"v0.7.4.1"
]
}