GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-h6m7-j4h3-9rf5critical9.6

Remote Code Execution in SyliusResourceBundle

Check your stack

The advisory, in context

Impact

Request parameters injected inside an expression evaluated by symfony/expression-language package haven't been sanitized properly. This allows the attacker to access any public service by manipulating that request parameter, allowing for Remote Code Execution.

The vulnerable versions include: <=1.3.13 || >=1.4.0 <=1.4.6 || >=1.5.0 <=1.5.1 || >=1.6.0 <=1.6.3.

Example

sylius_grid:
    grids:
        foo:
            fields:
                bar:
                    options:
                        baz: "expr:service('sylius.repository.product').find($id)"

In this case, $id can be prepared in a way that calls other services.

If you visit /route?id="~service('doctrine').getManager().getConnection().executeQuery("DELETE * FROM TABLE")~", it will result in a following expression expr:service('repository').find(""~service('doctrine').getManager().getConnection().executeQuery("DELETE * FROM TABLE")~""), which will execute a query on the currently connected database.

To find a vulnerability in your application, look for any routing definition that uses request parameters inside expression language.

Patches

This issue has been patched for versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4. Versions prior to 1.3 were not patched.

Workarounds

The fix requires adding addslashes in OptionsParser::parseOptionExpression to sanitize user input before evaluating it using the expression language.

- return is_string($variable) ? sprintf('"%s"', $variable) : $variable;
+ return is_string($variable) ? sprintf('"%s"', addslashes($variable)) : $variable;

Acknowledgements

This security issue has been reported by Craig Blanchette (@isometriks), thanks a lot!

For more information

If you have any questions or comments about this advisory:

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 1.4.0 before 1.4.7

Fixed in 1.4.7

7 explicitly affected versions

v1.4.0, v1.4.1, v1.4.2, v1.4.3, v1.4.4, v1.4.5, v1.4.6

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.4.0"
        },
        {
          "fixed": "1.4.7"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.4.0",
    "v1.4.1",
    "v1.4.2",
    "v1.4.3",
    "v1.4.4",
    "v1.4.5",
    "v1.4.6"
  ]
}
Ecosystem versions

From 1.5.0 before 1.5.2

Fixed in 1.5.2

2 explicitly affected versions

v1.5.0, v1.5.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.5.0"
        },
        {
          "fixed": "1.5.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.5.0",
    "v1.5.1"
  ]
}
Ecosystem versions

From 1.6.0 before 1.6.4

Fixed in 1.6.4

4 explicitly affected versions

v1.6.0, v1.6.1, v1.6.2, v1.6.3

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.6.0"
        },
        {
          "fixed": "1.6.4"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.6.0",
    "v1.6.1",
    "v1.6.2",
    "v1.6.3"
  ]
}
Ecosystem versions

From 1.0.0 before 1.3.14

Fixed in 1.3.14

73 explicitly affected versions

v1.0.0, v1.0.1, v1.0.10, v1.0.11, v1.0.12, v1.0.13, v1.0.14, v1.0.15, v1.0.16, v1.0.17, v1.0.18, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.0.6, v1.0.7, v1.0.8, v1.0.9, v1.1.0, v1.1.0-RC, v1.1.1, v1.1.10, v1.1.11, v1.1.12, v1.1.13, v1.1.14, v1.1.15, v1.1.17, v1.1.18, v1.1.2, v1.1.3, v1.1.4, v1.1.5, v1.1.6, v1.1.7, v1.1.8, v1.1.9, v1.2.0, v1.2.0-BETA, v1.2.0-RC, v1.2.1, v1.2.10, v1.2.11, v1.2.12, v1.2.13, v1.2.14, v1.2.15, v1.2.16, v1.2.17, v1.2.2, v1.2.3, v1.2.4, v1.2.5, v1.2.6, v1.2.7, v1.2.8, v1.2.9, v1.3.0, v1.3.0-BETA, v1.3.1, v1.3.10, v1.3.11, v1.3.12, v1.3.13, v1.3.2, v1.3.3, v1.3.4, v1.3.5, v1.3.6, v1.3.7, v1.3.8, v1.3.9

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.0.0"
        },
        {
          "fixed": "1.3.14"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.0.0",
    "v1.0.1",
    "v1.0.10",
    "v1.0.11",
    "v1.0.12",
    "v1.0.13",
    "v1.0.14",
    "v1.0.15",
    "v1.0.16",
    "v1.0.17",
    "v1.0.18",
    "v1.0.2",
    "v1.0.3",
    "v1.0.4",
    "v1.0.5",
    "v1.0.6",
    "v1.0.7",
    "v1.0.8",
    "v1.0.9",
    "v1.1.0",
    "v1.1.0-RC",
    "v1.1.1",
    "v1.1.10",
    "v1.1.11",
    "v1.1.12",
    "v1.1.13",
    "v1.1.14",
    "v1.1.15",
    "v1.1.17",
    "v1.1.18",
    "v1.1.2",
    "v1.1.3",
    "v1.1.4",
    "v1.1.5",
    "v1.1.6",
    "v1.1.7",
    "v1.1.8",
    "v1.1.9",
    "v1.2.0",
    "v1.2.0-BETA",
    "v1.2.0-RC",
    "v1.2.1",
    "v1.2.10",
    "v1.2.11",
    "v1.2.12",
    "v1.2.13",
    "v1.2.14",
    "v1.2.15",
    "v1.2.16",
    "v1.2.17",
    "v1.2.2",
    "v1.2.3",
    "v1.2.4",
    "v1.2.5",
    "v1.2.6",
    "v1.2.7",
    "v1.2.8",
    "v1.2.9",
    "v1.3.0",
    "v1.3.0-BETA",
    "v1.3.1",
    "v1.3.10",
    "v1.3.11",
    "v1.3.12",
    "v1.3.13",
    "v1.3.2",
    "v1.3.3",
    "v1.3.4",
    "v1.3.5",
    "v1.3.6",
    "v1.3.7",
    "v1.3.8",
    "v1.3.9"
  ]
}

References