GHSA-h63c-xvpf-264jcritical
ADOdb SQL injection vulnerability
No CVE assignedCheck your stack
The advisory, in context
The ADOdb Library for PHP prior to version 5.20.11 is prone to SQL Injection vulnerability in multiple drivers.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
adodb/adodb-php Packagist
Ecosystem versions
Earlier releases before 5.20.11
Fixed in 5.20.11
12 explicitly affected versions
v5.19, v5.20.0, v5.20.1, v5.20.10, v5.20.2, v5.20.3, v5.20.4, v5.20.5, v5.20.6, v5.20.7, v5.20.8, v5.20.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.20.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.19",
"v5.20.0",
"v5.20.1",
"v5.20.10",
"v5.20.2",
"v5.20.3",
"v5.20.4",
"v5.20.5",
"v5.20.6",
"v5.20.7",
"v5.20.8",
"v5.20.9"
]
}References
- https://github.com/ADOdb/ADOdb/pull/311
- https://github.com/ADOdb/ADOdb/pull/401
- https://github.com/dregad/ADOdb/commit/34788ce8c1d08500631f55764cc2247b9c7cfd2b
- https://github.com/dregad/ADOdb/commit/d29c23f2264ec95c6d3851e0f51ce240b2f36b74
- https://github.com/FriendsOfPHP/security-advisories/blob/master/adodb/adodb-php/2018-03-06.yaml