Yab Quarx persistent cross-site scripting vulnerability
The advisory, in context
Yab Quarx before 2.4.5 is prone to multiple persistent cross-site scripting vulnerabilities: Blog (Title), FAQ (Question), Pages (Title), Widgets (Name), and Menus (Name).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.4.5
Fixed in 2.4.5
116 explicitly affected versions
v0.1.1, v0.1.2, v0.1.3, v0.1.4, v0.1.5, v0.2.0, v0.2.1, v0.3.0, v0.3.1, v0.4.0, v0.5.0, v0.6.0, v0.6.1, v0.6.2, v0.6.3, v0.6.4, v0.6.5, v0.6.6, v0.7.0, v1.0.0, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.1.0, v1.2.0, v1.3.0, v1.3.1, v1.3.2, v1.3.3, v1.3.4, v1.3.5, v1.3.6, v1.4.0, v1.4.1, v1.4.10, v1.4.11, v1.4.12, v1.4.13, v1.4.14, v1.4.15, v1.4.16, v1.4.17, v1.4.18, v1.4.19, v1.4.2, v1.4.20, v1.4.21, v1.4.22, v1.4.23, v1.4.24, v1.4.3, v1.4.4, v1.4.5, v1.4.6, v1.4.7, v1.4.8, v1.4.9, v2.0.0, v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.12, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.2, v2.4.3, v2.4.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.1",
"v0.1.2",
"v0.1.3",
"v0.1.4",
"v0.1.5",
"v0.2.0",
"v0.2.1",
"v0.3.0",
"v0.3.1",
"v0.4.0",
"v0.5.0",
"v0.6.0",
"v0.6.1",
"v0.6.2",
"v0.6.3",
"v0.6.4",
"v0.6.5",
"v0.6.6",
"v0.7.0",
"v1.0.0",
"v1.0.1",
"v1.0.2",
"v1.0.3",
"v1.0.4",
"v1.0.5",
"v1.1.0",
"v1.2.0",
"v1.3.0",
"v1.3.1",
"v1.3.2",
"v1.3.3",
"v1.3.4",
"v1.3.5",
"v1.3.6",
"v1.4.0",
"v1.4.1",
"v1.4.10",
"v1.4.11",
"v1.4.12",
"v1.4.13",
"v1.4.14",
"v1.4.15",
"v1.4.16",
"v1.4.17",
"v1.4.18",
"v1.4.19",
"v1.4.2",
"v1.4.20",
"v1.4.21",
"v1.4.22",
"v1.4.23",
"v1.4.24",
"v1.4.3",
"v1.4.4",
"v1.4.5",
"v1.4.6",
"v1.4.7",
"v1.4.8",
"v1.4.9",
"v2.0.0",
"v2.0.1",
"v2.1.0",
"v2.1.1",
"v2.1.2",
"v2.1.3",
"v2.2.0",
"v2.2.1",
"v2.2.10",
"v2.2.11",
"v2.2.12",
"v2.2.2",
"v2.2.3",
"v2.2.4",
"v2.2.5",
"v2.2.6",
"v2.2.7",
"v2.2.8",
"v2.2.9",
"v2.3.0",
"v2.3.1",
"v2.3.10",
"v2.3.11",
"v2.3.12",
"v2.3.13",
"v2.3.14",
"v2.3.15",
"v2.3.16",
"v2.3.17",
"v2.3.18",
"v2.3.19",
"v2.3.2",
"v2.3.20",
"v2.3.21",
"v2.3.22",
"v2.3.23",
"v2.3.24",
"v2.3.25",
"v2.3.26",
"v2.3.27",
"v2.3.28",
"v2.3.29",
"v2.3.3",
"v2.3.30",
"v2.3.31",
"v2.3.32",
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7",
"v2.3.8",
"v2.3.9",
"v2.4.0",
"v2.4.1",
"v2.4.2",
"v2.4.3",
"v2.4.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-7274
- https://github.com/GrafiteInc/CMS/issues/115
- https://github.com/YABhq/Quarx/issues/116
- https://github.com/GrafiteInc/CMS/commit/dcc1a5ac3c6d48afd3b8b9d8b11a9c6bfeb75f77
- https://github.com/GrafiteInc/CMS
- http://seclists.org/bugtraq/2018/Feb/53
- http://www.securityfocus.com/bid/103081