GHSA-h3r9-pjmr-f938high7.5
Drupal Brute force amplification attacks via XML-RPC
The advisory, in context
The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks via a large number of calls made at once to the same method.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/core Packagist
Ecosystem versions
From 7.0 before 7.43
Fixed in 7.43
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0"
},
{
"fixed": "7.43"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}drupal/core Packagist
Ecosystem versions
From 6.0 before 6.38
Fixed in 6.38
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0"
},
{
"fixed": "6.38"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}drupal/drupal Packagist
Ecosystem versions
From 7.0 before 7.43
Fixed in 7.43
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0"
},
{
"fixed": "7.43"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}drupal/drupal Packagist
Ecosystem versions
From 6.0 before 6.38
Fixed in 6.38
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0"
},
{
"fixed": "6.38"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-3163
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2016-3163.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2016-3163.yaml
- https://github.com/drupal/core
- https://www.drupal.org/SA-CORE-2016-001
- http://www.debian.org/security/2016/dsa-3498
- http://www.openwall.com/lists/oss-security/2016/02/24/19
- http://www.openwall.com/lists/oss-security/2016/03/15/10