GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-gxxc-m74c-f48xmedium6.1

October CMS Vulnerable to Stored XSS via Editor and Branding Styles

Impact

A cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms:

Source excerpt · OSV

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected rangeRecorded fix
Earlier releases before 3.7.13Ecosystem versions3.7.13
From 4.0.0 before 4.0.12Ecosystem versions4.0.12

Version evidence: OSV · GHSA-gxxc-m74c-f48x

View original version evidence (169 explicit versions)

Original source description

A cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms:

  • Editor Settings Markup Styles
    A user with the Global Editor Settings permission could inject malicious HTML/JS into the stylesheet input at
    Settings → Editor Settings → Markup Styles.

A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users.


Impact

  • Persistent XSS across the backend interface.
  • Exploitable by lower-privileged accounts with the above permissions.
  • Potential consequences include privilege escalation, session hijacking, and execution of unauthorized actions in victim sessions.

Patches

The vulnerability has been patched in v4.0.12 and v3.7.13.
Stylesheet inputs are now sanitized to prevent injection of arbitrary HTML/JS.

All users are strongly encouraged to upgrade to the latest patched version.


Workarounds

If upgrading immediately is not possible:

  • Restrict the permissions Global Editor Settings to fully trusted administrators only.

This reduces exposure but does not fully eliminate risk.


Credits

References