GHSA-gxwx-c7m8-f95hhigh7.4
Drupal Open redirect vulnerability in the drupal_goto function
The advisory, in context
Open redirect vulnerability in the drupal_goto function in Drupal 6.x before 6.38, when used with PHP before 5.4.7, allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a double-encoded URL in the "destination" parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/core Packagist
Ecosystem versions
From 6.0 before 6.38
Fixed in 6.38
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0"
},
{
"fixed": "6.38"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}drupal/drupal Packagist
Ecosystem versions
From 6.0 before 6.38
Fixed in 6.38
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0"
},
{
"fixed": "6.38"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-3167
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2016-3167.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2016-3167.yaml
- https://github.com/drupal/core
- https://www.drupal.org/SA-CORE-2016-001
- http://www.debian.org/security/2016/dsa-3498
- http://www.openwall.com/lists/oss-security/2016/02/24/19
- http://www.openwall.com/lists/oss-security/2016/03/15/10