GHSA-gwwq-54qp-9pgphigh8.8
Zend Framework CSRF Vulnerability
The advisory, in context
Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
zendframework/zendframework Packagist
Ecosystem versions
From 2.3.0 before 2.3.6
Fixed in 2.3.6
6 explicitly affected versions
2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.3.0",
"2.3.1",
"2.3.2",
"2.3.3",
"2.3.4",
"2.3.5"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1786
- https://github.com/zendframework/zendframework/commit/213d2c490f55331ba4e5e3884bd81d13d1eb0aee
- https://bugzilla.redhat.com/show_bug.cgi?id=1207781
- https://framework.zend.com/changelog/2.3.6
- https://framework.zend.com/security/advisory/ZF2015-03
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework/CVE-2015-1786.yaml
- https://github.com/zendframework/zf-web/blob/f97fe5c3cf6c51df7502237c6342511802c8df22/module/Security/view/security/advisory/ZF2015-03.phtml
- https://github.com/zendframework/zf3-web/blob/5852ab5bfd47285e6b46f9e7b13250629b3e372e/data/advisories/ZF2015-03.md