GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-gvpp-6jrj-5pqcmedium6.1

Zend-Form vulnerable to Cross-site Scripting

No CVE assignedCheck your stack

The advisory, in context

Many Zend Framework 2 view helpers were using the escapeHtml() view helper in order to escape HTML attributes, instead of the more appropriate escapeHtmlAttr(). In situations where user data and/or JavaScript is used to seed attributes, this can lead to potential cross site scripting (XSS) attack vectors.

Vulnerable view helpers include:

  • All Zend\Form view helpers.
  • Most Zend\Navigation (aka Zend\View\Helper\Navigation\*) view helpers.
  • All "HTML Element" view helpers: htmlFlash(), htmlPage(), htmlQuickTime().
  • Zend\View\Helper\Gravatar

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 2.0.0 before 2.2.7

Fixed in 2.2.7

23 explicitly affected versions

2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.2.0, 2.2.0rc1, 2.2.0rc2, 2.2.0rc3, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.0.0"
        },
        {
          "fixed": "2.2.7"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "2.0.3",
    "2.0.4",
    "2.0.5",
    "2.0.6",
    "2.0.7",
    "2.0.8",
    "2.1.0",
    "2.1.1",
    "2.1.2",
    "2.1.3",
    "2.1.4",
    "2.1.5",
    "2.1.6",
    "2.2.0",
    "2.2.0rc1",
    "2.2.0rc2",
    "2.2.0rc3",
    "2.2.1",
    "2.2.2",
    "2.2.3",
    "2.2.4",
    "2.2.5",
    "2.2.6"
  ]
}
Ecosystem versions

From 2.3.0 before 2.3.1

Fixed in 2.3.1

1 explicitly affected versions

2.3.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.3.0"
        },
        {
          "fixed": "2.3.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "2.3.0"
  ]
}

References