Moodle directory traversal vulnerability
The advisory, in context
Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.6.8
Fixed in 2.6.8
43 explicitly affected versions
v2.3.10, v2.3.11, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.0-rc1, v2.4.1, v2.4.10, v2.4.11, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.0-beta, v2.5.0-rc1, v2.5.1, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.0-beta, v2.6.0-rc1, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.3.10",
"v2.3.11",
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7",
"v2.3.8",
"v2.3.9",
"v2.4.0",
"v2.4.0-rc1",
"v2.4.1",
"v2.4.10",
"v2.4.11",
"v2.4.2",
"v2.4.3",
"v2.4.4",
"v2.4.5",
"v2.4.6",
"v2.4.7",
"v2.4.8",
"v2.4.9",
"v2.5.0",
"v2.5.0-beta",
"v2.5.0-rc1",
"v2.5.1",
"v2.5.2",
"v2.5.3",
"v2.5.4",
"v2.5.5",
"v2.5.6",
"v2.5.7",
"v2.5.8",
"v2.5.9",
"v2.6.0",
"v2.6.0-beta",
"v2.6.0-rc1",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.6.4",
"v2.6.5",
"v2.6.6",
"v2.6.7"
]
}From 2.7.0 before 2.7.5
Fixed in 2.7.5
5 explicitly affected versions
v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.7.0"
},
{
"fixed": "2.7.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.7.0",
"v2.7.1",
"v2.7.2",
"v2.7.3",
"v2.7.4"
]
}From 2.8.0 before 2.8.3
Fixed in 2.8.3
3 explicitly affected versions
v2.8.0, v2.8.1, v2.8.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.8.0"
},
{
"fixed": "2.8.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.8.0",
"v2.8.1",
"v2.8.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1493
- https://github.com/moodle/moodle/commit/0289be1321babfa588fb5b18ebb08a296eed9eee
- https://github.com/moodle/moodle/commit/a72f2cca7f08c354c18a3923c3f05eee50bdd434
- https://github.com/moodle/moodle/commit/af9a7937cc085f96bdbc4724cadec6eeae0242fc
- https://github.com/moodle/moodle/commit/cc496f5b27d36a8df4bcede997a484eb9719363b
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=279956
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-48980
- http://git.moodle.org/gw?p=moodle.git;a=commit;h=af9a7937cc085f96bdbc4724cadec6eeae0242fc
- http://openwall.com/lists/oss-security/2015/02/04/15
- http://openwall.com/lists/oss-security/2015/02/09/2