Magento LTS vulnerable to stored XSS in admin file form
The advisory, in context
Summary
OpenMage is affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields.
Details
Mage_Adminhtml_Block_System_Config_Form_Field_File does not escape filename value in certain situations.
Same as: https://nvd.nist.gov/vuln/detail/CVE-2024-20717
PoC
- Create empty file with this filename:
<img src=x onerror=alert(1)>.crt - Go to System > Configuration > Sales | Payment Methonds.
- Click Configure on PayPal Express Checkout.
- Choose API Certificate from dropdown API Authentication Methods.
- Choose the XSS-file and click Save Config.
- Profit, alerts "1" -> XSS.
- Reload, alerts "1" -> Stored XSS.
Impact
Affects admins that have access to any fileupload field in admin in core or custom implementations. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 20.0.0 before 20.5.0
Fixed in 20.5.0
32 explicitly affected versions
v20.0.0, v20.0.1, v20.0.10, v20.0.11, v20.0.12, v20.0.13, v20.0.14, v20.0.15, v20.0.16, v20.0.17, v20.0.18, v20.0.19, v20.0.2, v20.0.20, v20.0.3, v20.0.4, v20.0.5, v20.0.6, v20.0.7, v20.0.8, v20.1.0, v20.1.0-rc1, v20.1.0-rc2, v20.1.0-rc3, v20.1.0-rc4, v20.1.0-rc5, v20.1.0-rc6, v20.1.0-rc7, v20.1.1, v20.2.0, v20.3.0, v20.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "20.0.0"
},
{
"fixed": "20.5.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v20.0.0",
"v20.0.1",
"v20.0.10",
"v20.0.11",
"v20.0.12",
"v20.0.13",
"v20.0.14",
"v20.0.15",
"v20.0.16",
"v20.0.17",
"v20.0.18",
"v20.0.19",
"v20.0.2",
"v20.0.20",
"v20.0.3",
"v20.0.4",
"v20.0.5",
"v20.0.6",
"v20.0.7",
"v20.0.8",
"v20.1.0",
"v20.1.0-rc1",
"v20.1.0-rc2",
"v20.1.0-rc3",
"v20.1.0-rc4",
"v20.1.0-rc5",
"v20.1.0-rc6",
"v20.1.0-rc7",
"v20.1.1",
"v20.2.0",
"v20.3.0",
"v20.4.0"
]
}Earlier releases before 19.5.3
Fixed in 19.5.3
40 explicitly affected versions
1.9.1.1, 1.9.2.0, 1.9.2.1, 1.9.2.2, 1.9.2.3, 1.9.2.4, 1.9.3.0, 1.9.3.1, v19.4.0, v19.4.1, v19.4.10, v19.4.11, v19.4.12, v19.4.13, v19.4.14, v19.4.15, v19.4.16, v19.4.17, v19.4.18, v19.4.19, v19.4.2, v19.4.20, v19.4.21, v19.4.22, v19.4.23, v19.4.3, v19.4.4, v19.4.5, v19.4.6, v19.4.7, v19.4.8, v19.4.9, v19.5.0, v19.5.0-rc1, v19.5.0-rc2, v19.5.0-rc3, v19.5.0-rc4, v19.5.0-rc5, v19.5.1, v19.5.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "19.5.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.9.1.1",
"1.9.2.0",
"1.9.2.1",
"1.9.2.2",
"1.9.2.3",
"1.9.2.4",
"1.9.3.0",
"1.9.3.1",
"v19.4.0",
"v19.4.1",
"v19.4.10",
"v19.4.11",
"v19.4.12",
"v19.4.13",
"v19.4.14",
"v19.4.15",
"v19.4.16",
"v19.4.17",
"v19.4.18",
"v19.4.19",
"v19.4.2",
"v19.4.20",
"v19.4.21",
"v19.4.22",
"v19.4.23",
"v19.4.3",
"v19.4.4",
"v19.4.5",
"v19.4.6",
"v19.4.7",
"v19.4.8",
"v19.4.9",
"v19.5.0",
"v19.5.0-rc1",
"v19.5.0-rc2",
"v19.5.0-rc3",
"v19.5.0-rc4",
"v19.5.0-rc5",
"v19.5.1",
"v19.5.2"
]
}