GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-gg8r-xjwq-4w92medium5.4

Cross-site scripting vulnerability in TinyMCE alerts

Impact

A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the image plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user.

Source excerpt · OSV

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected rangeRecorded fix
From 6.0.0 before 6.3.1Semantic versions6.3.1
Earlier releases before 5.10.7Semantic versions5.10.7

Version evidence: OSV · GHSA-gg8r-xjwq-4w92

View original version evidence (0 explicit versions)
Affected rangeRecorded fix
From 6.0.0 before 6.3.1Ecosystem versions6.3.1
Earlier releases before 5.10.7Ecosystem versions5.10.7

Version evidence: OSV · GHSA-gg8r-xjwq-4w92

View original version evidence (179 explicit versions)
Affected rangeRecorded fix
From 6.0.0 before 6.3.1Ecosystem versions6.3.1
Earlier releases before 5.10.7Ecosystem versions5.10.7

Version evidence: OSV · GHSA-gg8r-xjwq-4w92

View original version evidence (188 explicit versions)

Original source description

Impact

A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the image plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user.

Patches

This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements.

Fix

To avoid this vulnerability:

  • Upgrade to TinyMCE 5.10.7 or higher for TinyMCE 5.x.
  • Upgrade to TinyMCE 6.3.1 or higher for TinyMCE 6.x.

Workaround

To reduce the impact of this vulnerability:

  • Ensure the the images_upload_handler returns a valid value as per the images_upload_handler documentation.

References

For more information

If you have any questions or comments about this advisory:

References