GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-gcgp-q2jq-fw52low3.5

LibreNMS has Stored Cross-site Scripting vulnerability in "Alert Templates" feature

Check your stack

The advisory, in context

Summary

A Self Cross-Site Scripting (Self-XSS) vulnerability in the "Alert Templates" feature allows users to inject arbitrary JavaScript into the alert template's name. This script executes immediately upon submission but does not persist after a page refresh.

Details

The vulnerability occurs when creating an alert template in the LibreNMS interface. Although the application sanitizes the "name" field when storing it in the database, this newly created template is immediately added to the table without any sanitization being applied to the name, allowing users to inject arbitrary JavaScript. This script executes when the template is created but does not persist in the database, thus preventing stored XSS.

For instance, the following payload can be used to exploit the vulnerability: test1<script>{onerror=alert}throw 1337</script>

The root cause of this vulnerability lies in the lack of sanitization of the "name" variable before it is rendered in the table. The vulnerability exists because the bootgrid function of the jQuery grid plugin does not sanitize the text being added to the table. Although tags are stripped before being added to the database (as shown in the code below), the vulnerability still allows Self-XSS during the creation of the template.

Where the variable is being sanitized before being stored in the database: https://github.com/librenms/librenms/blob/0e741e365aa974a74aee6b43d1b4b759158a5c7e/includes/html/forms/alert-templates.inc.php#L40

Where the vulnerability is happening: https://github.com/librenms/librenms/blob/0e741e365aa974a74aee6b43d1b4b759158a5c7e/includes/html/modal/alert_template.inc.php#L205

PoC

  1. Navigate to the "Alert Templates" creation page in the LibreNMS interface.
  2. In the "Name" field, input the following payload: test1<script>{onerror=alert}throw 1337</script>
  3. Submit the form to create the alert template.
  4. Observe that the JavaScript executes immediately, triggering an alert popup. However, this code does not persist after refreshing the page.

Impact

This is a Self Cross-Site Scripting (Self-XSS) vulnerability. Although the risk is lower compared to traditional XSS, it can still be exploited through social engineering or tricking users into entering or interacting with malicious code. This can lead to unauthorized actions or data exposure in the context of the affected user's session.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 24.9.0

Fixed in 24.9.0

128 explicitly affected versions

1.19, 1.20, 1.20.1, 1.21, 1.22, 1.22.01, 1.23, 1.24, 1.25, 1.26, 1.27, 1.28, 1.29, 1.30, 1.30.01, 1.31, 1.31.01, 1.31.02, 1.31.03, 1.32, 1.32.01, 1.33, 1.33.01, 1.34, 1.35, 1.36, 1.36.01, 1.37, 1.38, 1.39, 1.40, 1.41, 1.42, 1.42.01, 1.43, 1.44, 1.45, 1.46, 1.47, 1.48, 1.48.1, 1.49, 1.50, 1.50.1, 1.51, 1.52, 1.53, 1.53.1, 1.54, 1.55, 1.56, 1.57, 1.58, 1.58.1, 1.59, 1.60, 1.61, 1.62, 1.62.1, 1.62.2, 1.63, 1.64, 1.64.1, 1.65, 1.65.1, 1.66, 1.67, 1.68, 1.69, 1.70.0, 1.70.1, 21.1.0, 21.10.0, 21.10.1, 21.10.2, 21.11.0, 21.12.0, 21.12.1, 21.2.0, 21.3.0, 21.4.0, 21.5.0, 21.5.1, 21.6.0, 21.7.0, 21.8.0, 21.9.0, 21.9.1, 22.1.0, 22.10.0, 22.11.0, 22.12.0, 22.2.0, 22.2.1, 22.2.2, 22.3.0, 22.4.0, 22.4.1, 22.5.0, 22.6.0, 22.7.0, 22.8.0, 22.9.0, 23.1.0, 23.1.1, 23.10.0, 23.11.0, 23.2.0, 23.4.0, 23.4.1, 23.5.0, 23.6.0, 23.7.0, 23.8.0, 23.8.1, 23.8.2, 23.9.0, 23.9.1, 24.1.0, 24.2.0, 24.3.0, 24.4.0, 24.4.1, 24.5.0, 24.6.0, 24.7.0, 24.8.0, 24.8.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "24.9.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.19",
    "1.20",
    "1.20.1",
    "1.21",
    "1.22",
    "1.22.01",
    "1.23",
    "1.24",
    "1.25",
    "1.26",
    "1.27",
    "1.28",
    "1.29",
    "1.30",
    "1.30.01",
    "1.31",
    "1.31.01",
    "1.31.02",
    "1.31.03",
    "1.32",
    "1.32.01",
    "1.33",
    "1.33.01",
    "1.34",
    "1.35",
    "1.36",
    "1.36.01",
    "1.37",
    "1.38",
    "1.39",
    "1.40",
    "1.41",
    "1.42",
    "1.42.01",
    "1.43",
    "1.44",
    "1.45",
    "1.46",
    "1.47",
    "1.48",
    "1.48.1",
    "1.49",
    "1.50",
    "1.50.1",
    "1.51",
    "1.52",
    "1.53",
    "1.53.1",
    "1.54",
    "1.55",
    "1.56",
    "1.57",
    "1.58",
    "1.58.1",
    "1.59",
    "1.60",
    "1.61",
    "1.62",
    "1.62.1",
    "1.62.2",
    "1.63",
    "1.64",
    "1.64.1",
    "1.65",
    "1.65.1",
    "1.66",
    "1.67",
    "1.68",
    "1.69",
    "1.70.0",
    "1.70.1",
    "21.1.0",
    "21.10.0",
    "21.10.1",
    "21.10.2",
    "21.11.0",
    "21.12.0",
    "21.12.1",
    "21.2.0",
    "21.3.0",
    "21.4.0",
    "21.5.0",
    "21.5.1",
    "21.6.0",
    "21.7.0",
    "21.8.0",
    "21.9.0",
    "21.9.1",
    "22.1.0",
    "22.10.0",
    "22.11.0",
    "22.12.0",
    "22.2.0",
    "22.2.1",
    "22.2.2",
    "22.3.0",
    "22.4.0",
    "22.4.1",
    "22.5.0",
    "22.6.0",
    "22.7.0",
    "22.8.0",
    "22.9.0",
    "23.1.0",
    "23.1.1",
    "23.10.0",
    "23.11.0",
    "23.2.0",
    "23.4.0",
    "23.4.1",
    "23.5.0",
    "23.6.0",
    "23.7.0",
    "23.8.0",
    "23.8.1",
    "23.8.2",
    "23.9.0",
    "23.9.1",
    "24.1.0",
    "24.2.0",
    "24.3.0",
    "24.4.0",
    "24.4.1",
    "24.5.0",
    "24.6.0",
    "24.7.0",
    "24.8.0",
    "24.8.1"
  ]
}

References