GHSA-g9m2-c2x5-fr2vmedium5.4
Moodle does not revoke role capabilities correctly
The advisory, in context
A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.7.0 before 3.7.3
Fixed in 3.7.3
3 explicitly affected versions
v3.7.0, v3.7.1, v3.7.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.7.0"
},
{
"fixed": "3.7.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.7.0",
"v3.7.1",
"v3.7.2"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.6.0 before 3.6.7
Fixed in 3.6.7
7 explicitly affected versions
v3.6.0, v3.6.1, v3.6.2, v3.6.3, v3.6.4, v3.6.5, v3.6.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.6.0"
},
{
"fixed": "3.6.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.6.0",
"v3.6.1",
"v3.6.2",
"v3.6.3",
"v3.6.4",
"v3.6.5",
"v3.6.6"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.5.0 before 3.5.9
Fixed in 3.5.9
9 explicitly affected versions
v3.5.0, v3.5.1, v3.5.2, v3.5.3, v3.5.4, v3.5.5, v3.5.6, v3.5.7, v3.5.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5.0"
},
{
"fixed": "3.5.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.5.0",
"v3.5.1",
"v3.5.2",
"v3.5.3",
"v3.5.4",
"v3.5.5",
"v3.5.6",
"v3.5.7",
"v3.5.8"
]
}