GHSA-g8v9-c8m3-942vcritical9.8
Remote code execution in php-heic-to-jpg
The advisory, in context
php-heic-to-jpg < 1.0.5 is vulnerable to remote code execution. An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg below 1.0.5.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
maestroerror/php-heic-to-jpg Packagist
Ecosystem versions
Earlier releases before 1.0.5
Fixed in 1.0.5
11 explicitly affected versions
v0.1, v0.2, v0.3, v0.3.1, v0.3.2, v0.4.0, v1.0, v1.0.1, v1.0.2, v1.0.3, v1.0.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1",
"v0.2",
"v0.3",
"v0.3.1",
"v0.3.2",
"v0.4.0",
"v1.0",
"v1.0.1",
"v1.0.2",
"v1.0.3",
"v1.0.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2024-48514
- https://github.com/MaestroError/php-heic-to-jpg/pull/34
- https://advisories.gitlab.com/pkg/composer/maestroerror/php-heic-to-jpg/CVE-2024-48514
- https://github.com/MaestroError/php-heic-to-jpg
- https://github.com/advisories/GHSA-g8v9-c8m3-942v
- https://github.com/marcoris/CVEs/tree/master/CVE-2024-48514