GHSA-fx37-56v6-85q6high8.8
Silverstripe CSRF Protection Bypass via GraphQL
The advisory, in context
In SilverStripe/GraphQL prior to 2.0.5 and 3.1.2, the previous fix for SS-2018-007 does not completely mitigate the risk of CSRF in GraphQL mutations.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
silverstripe/graphql Packagist
Ecosystem versions
From 2.0.0 before 2.0.5
Fixed in 2.0.5
5 explicitly affected versions
2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3",
"2.0.4"
]
}silverstripe/graphql Packagist
Ecosystem versions
From 3.1.0 before 3.1.2
Fixed in 3.1.2
2 explicitly affected versions
3.1.0, 3.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.1.0"
},
{
"fixed": "3.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.1.0",
"3.1.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12437
- https://github.com/silverstripe/silverstripe-graphql/commit/3c1dd6b839b7c0e2cbc85074bb5840ebded6097c
- https://github.com/silverstripe/silverstripe-graphql/commit/db28f3075ae2335905f43ac808e9177497e354ff
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/graphql/CVE-2019-12437.yaml
- https://github.com/silverstripe/silverstripe-graphql
- https://www.silverstripe.org/download/security-releases/cve-2019-12437