VuFind Server-Side Request Forgery (SSRF) vulnerability
The advisory, in context
A Server-Side Request Forgery (SSRF) vulnerability in the /Cover/Show route (showAction in CoverController.php) in Open Library Foundation VuFind 2.4 through 9.1 before 9.1.1 allows remote attackers to access internal HTTP servers and perform Cross-Site Scripting (XSS) attacks by proxying arbitrary URLs via the proxy GET parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.4 before 9.1.1
Fixed in 9.1.1
49 explicitly affected versions
v2.4, v2.4.1, v2.5, v2.5.1, v2.5.2, v2.5.3, v2.5.4, v3.0, v3.0.1, v3.0.2, v3.0.3, v3.1, v3.1.1, v3.1.2, v3.1.3, v3.1.4, v4.0, v4.0.1, v4.1, v4.1.1, v4.1.2, v4.1.3, v5.0, v5.0.1, v5.1, v5.1.1, v6.0, v6.0.1, v6.1, v6.1.1, v6.1.2, v7.0, v7.0.1, v7.0.2, v7.1, v7.1.1, v8.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1, v8.1.1, v8.1.2, v9.0, v9.0.1, v9.0.2, v9.0.3, v9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4"
},
{
"fixed": "9.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.4",
"v2.4.1",
"v2.5",
"v2.5.1",
"v2.5.2",
"v2.5.3",
"v2.5.4",
"v3.0",
"v3.0.1",
"v3.0.2",
"v3.0.3",
"v3.1",
"v3.1.1",
"v3.1.2",
"v3.1.3",
"v3.1.4",
"v4.0",
"v4.0.1",
"v4.1",
"v4.1.1",
"v4.1.2",
"v4.1.3",
"v5.0",
"v5.0.1",
"v5.1",
"v5.1.1",
"v6.0",
"v6.0.1",
"v6.1",
"v6.1.1",
"v6.1.2",
"v7.0",
"v7.0.1",
"v7.0.2",
"v7.1",
"v7.1.1",
"v8.0",
"v8.0.1",
"v8.0.2",
"v8.0.3",
"v8.0.4",
"v8.1",
"v8.1.1",
"v8.1.2",
"v9.0",
"v9.0.1",
"v9.0.2",
"v9.0.3",
"v9.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2024-25737
- https://github.com/vufind-org/vufind/commit/345d00f7d7f1c581f46742effdac70e803b3847b
- https://github.com/vufind-org/vufind/commit/51f2ddac0dc1047e6fd3b27e6d984b19e1601d00
- https://github.com/vufind-org/vufind
- https://vufind.org/wiki/security:cve-2024-25737