GHSA-fw3x-2pr2-5j64high8.7
GeSHi vulnerable to Directory Traversal
The advisory, in context
Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before 1.0.8.11 allow remote attackers to read arbitrary files via a .. (dot dot) in the (1) geshi-path or (2) geshi-lang-path parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
geshi/geshi Packagist
Ecosystem versions
Earlier releases before 1.0.8.11
Fixed in 1.0.8.11
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.8.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2012-3521
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=685324
- https://github.com/GeSHi/geshi-1.0
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/105247.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/105273.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/105317.html
- http://sourceforge.net/p/geshi/code/2507
- http://www.openwall.com/lists/oss-security/2012/08/21/11