Backport for CVE-2021-21024 Blind SQLi from Magento 2
The advisory, in context
Impact
This vulnerability allows an administrator unauthorized access to restricted resources.
We fixed a vulnerability in the MySQL adapter to prevent SQL injection attacks. This is a backport of CVE-2021-21024 https://helpx.adobe.com/security/products/magento/apsb21-08.html.
Patches
Has the problem been patched? What versions should users upgrade to?
v20.0.9 v19.4.13
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 19.4.13
Fixed in 19.4.13
21 explicitly affected versions
1.9.1.1, 1.9.2.0, 1.9.2.1, 1.9.2.2, 1.9.2.3, 1.9.2.4, 1.9.3.0, 1.9.3.1, v19.4.0, v19.4.1, v19.4.10, v19.4.11, v19.4.12, v19.4.2, v19.4.3, v19.4.4, v19.4.5, v19.4.6, v19.4.7, v19.4.8, v19.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "19.4.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.9.1.1",
"1.9.2.0",
"1.9.2.1",
"1.9.2.2",
"1.9.2.3",
"1.9.2.4",
"1.9.3.0",
"1.9.3.1",
"v19.4.0",
"v19.4.1",
"v19.4.10",
"v19.4.11",
"v19.4.12",
"v19.4.2",
"v19.4.3",
"v19.4.4",
"v19.4.5",
"v19.4.6",
"v19.4.7",
"v19.4.8",
"v19.4.9"
]
}From 20.0.0 before 20.0.9
Fixed in 20.0.9
9 explicitly affected versions
v20.0.0, v20.0.1, v20.0.2, v20.0.3, v20.0.4, v20.0.5, v20.0.6, v20.0.7, v20.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "20.0.0"
},
{
"fixed": "20.0.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v20.0.0",
"v20.0.1",
"v20.0.2",
"v20.0.3",
"v20.0.4",
"v20.0.5",
"v20.0.6",
"v20.0.7",
"v20.0.8"
]
}